[MOD 0.14] AAI Programmable Vehicles

Topics and discussion about specific mods
Inspired
Burner Inserter
Burner Inserter
Posts: 5
Joined: Mon Nov 03, 2014 9:43 pm
Contact:

Re: [MOD 0.14] AAI Programmable Vehicles

Post by Inspired »

Bug Report

Problem: Error when a vehicle is unable to find a path while a player is in it. Also the player dies in the process :o
Example: https://www.dropbox.com/s/d9kbbh1b9kxaj ... 0.png?dl=0

How to reproduce:
1) Put a player inside any vehicle
2) Set vehicle AI to always on (green)
3) Build a wall around it
4) Give the vehicle the command to go outside the enclosed area
5) After a few attempts player is killed and crash notice is displayed

It does not always happen, but has a very high chance.

Rouks
Burner Inserter
Burner Inserter
Posts: 5
Joined: Thu Mar 10, 2016 9:09 pm
Contact:

Update for Factorio 16 ?

Post by Rouks »

Hello,
Is there any update in view for Factorio 0.16.x?

IanRaven
Inserter
Inserter
Posts: 20
Joined: Fri Jan 19, 2018 9:58 am
Contact:

Re: Update for Factorio 16 ?

Post by IanRaven »

Rouks wrote:Hello,
Is there any update in view for Factorio 0.16.x?
Lol, just check the page before this one.

User avatar
Earendel
Filter Inserter
Filter Inserter
Posts: 691
Joined: Sun Nov 23, 2014 11:57 am
Contact:

Re: Update for Factorio 16 ?

Post by Earendel »

Rouks wrote:Hello,
Is there any update in view for Factorio 0.16.x?
I'm working through the issues that people have reported with the test version, but this bug with the base game is a blocker:
viewtopic.php?f=23&t=56663
It's currently marked as 'not a bug', but surely killing the player is not intentional.
I can't release a version where the player randomly dies if a vehicle changes pathfinding modes.

RocketManChronicles
Filter Inserter
Filter Inserter
Posts: 334
Joined: Mon Aug 01, 2016 2:38 pm
Contact:

Re: Update for Factorio 16 ?

Post by RocketManChronicles »

Earendel wrote:
Rouks wrote:Hello,
Is there any update in view for Factorio 0.16.x?
I'm working through the issues that people have reported with the test version, but this bug with the base game is a blocker:
viewtopic.php?f=23&t=56663
It's currently marked as 'not a bug', but surely killing the player is not intentional.
I can't release a version where the player randomly dies if a vehicle changes pathfinding modes.
If I am understanding this bug correctly, the player dies either when the vehicle he is in is replaced or when riding passenger and the AI On state automatically starts moving the vehicle?

I have just downloaded your latest version to start a new (heavily) modded play-through. I am hoping to help find bugs but wanted to fully understand the debilitating bug better.

User avatar
Earendel
Filter Inserter
Filter Inserter
Posts: 691
Joined: Sun Nov 23, 2014 11:57 am
Contact:

Re: Update for Factorio 16 ?

Post by Earendel »

RocketManChronicles wrote:
Earendel wrote:
Rouks wrote:Hello,
Is there any update in view for Factorio 0.16.x?
I'm working through the issues that people have reported with the test version, but this bug with the base game is a blocker:
viewtopic.php?f=23&t=56663
It's currently marked as 'not a bug', but surely killing the player is not intentional.
I can't release a version where the player randomly dies if a vehicle changes pathfinding modes.
If I am understanding this bug correctly, the player dies either when the vehicle he is in is replaced or when riding passenger and the AI On state automatically starts moving the vehicle?

I have just downloaded your latest version to start a new (heavily) modded play-through. I am hoping to help find bugs but wanted to fully understand the debilitating bug better.
After more testing I found that the problem is more complicated, and related to the player being unable to exit the vehicle using any of the current api calls.
I made a separate bug report here with more details:
viewtopic.php?f=7&t=57068

Basically, when the vehicle moves around it might end up somewhere that the player can't exit, and if the vehicle mode changes at that time the player is killed. (Mode change means swapping vehicles). I can't find any way around the problem, even teleporting the old vehicle to a clear area and creating the new vehicle in a separate clear area doesn't work.

RocketManChronicles
Filter Inserter
Filter Inserter
Posts: 334
Joined: Mon Aug 01, 2016 2:38 pm
Contact:

Re: Update for Factorio 16 ?

Post by RocketManChronicles »

Earendel wrote:
RocketManChronicles wrote:
Earendel wrote:
Rouks wrote:Hello,
Is there any update in view for Factorio 0.16.x?
I'm working through the issues that people have reported with the test version, but this bug with the base game is a blocker:
viewtopic.php?f=23&t=56663
It's currently marked as 'not a bug', but surely killing the player is not intentional.
I can't release a version where the player randomly dies if a vehicle changes pathfinding modes.
If I am understanding this bug correctly, the player dies either when the vehicle he is in is replaced or when riding passenger and the AI On state automatically starts moving the vehicle?

I have just downloaded your latest version to start a new (heavily) modded play-through. I am hoping to help find bugs but wanted to fully understand the debilitating bug better.
After more testing I found that the problem is more complicated, and related to the player being unable to exit the vehicle using any of the current api calls.
I made a separate bug report here with more details:
viewtopic.php?f=7&t=57068

Basically, when the vehicle moves around it might end up somewhere that the player can't exit, and if the vehicle mode changes at that time the player is killed. (Mode change means swapping vehicles). I can't find any way around the problem, even teleporting the old vehicle to a clear area and creating the new vehicle in a separate clear area doesn't work.
Alright, makes sense to me now. Hopefully, they look at this bug report. Thank you for the update! I will be testing the mod as it is and let you know if I come across anything else.

User avatar
CakeDog
Inserter
Inserter
Posts: 20
Joined: Sun Jun 25, 2017 12:48 am
Contact:

Re: [MOD 0.14] AAI Programmable Vehicles

Post by CakeDog »

Here's hoping to that.

As an aside, I really haven't had any issues with the latest build. Smooth sailing for my 5 automated haulers.

User avatar
Earendel
Filter Inserter
Filter Inserter
Posts: 691
Joined: Sun Nov 23, 2014 11:57 am
Contact:

Re: [MOD 0.14] AAI Programmable Vehicles

Post by Earendel »

I've had some promising responses from two of the bug reports I submitted so hopefully Factorio 0.16.21 will fix some of the problems I can't work around. I don't know when 0.16.21 will be released, but if it does fix things I should be able to release the remaining 0.16 compatible AAI versions within a few days of that.

RocketManChronicles
Filter Inserter
Filter Inserter
Posts: 334
Joined: Mon Aug 01, 2016 2:38 pm
Contact:

Re: [MOD 0.14] AAI Programmable Vehicles

Post by RocketManChronicles »

Earendel wrote:I've had some promising responses from two of the bug reports I submitted so hopefully Factorio 0.16.21 will fix some of the problems I can't work around. I don't know when 0.16.21 will be released, but if it does fix things I should be able to release the remaining 0.16 compatible AAI versions within a few days of that.
That is promising news indeed! If it means anything, I have not run into any issues so far in my single-player game. (Of course I have not entered any of the vehicles either).

Thank you for your dedication and bringing us some incredible mods!

User avatar
Earendel
Filter Inserter
Filter Inserter
Posts: 691
Joined: Sun Nov 23, 2014 11:57 am
Contact:

Re: [MOD 0.14] AAI Programmable Vehicles

Post by Earendel »

I plan to release the 0.16 versions tomorrow morning. Most stuff is working but there are still some general pathfinding problems. Vehicles have problems over long distances, sometimes get stuck in a loop crashing into a tree or rock. I think some of it can be improved by tweaking some values, but it's difficult to detect problems where it's stuck but not fully stopped, and also difficult to determine a different behaviour that will help in most situations and not just make it worse. Overall it seems a bit better than the 0.15 version but it's highly subjective and environment dependant. Feedback on where the pathfinding is better or worse than the 0.15 versions would be useful.

RocketManChronicles
Filter Inserter
Filter Inserter
Posts: 334
Joined: Mon Aug 01, 2016 2:38 pm
Contact:

Re: [MOD 0.14] AAI Programmable Vehicles

Post by RocketManChronicles »

Earendel wrote:I plan to release the 0.16 versions tomorrow morning. Most stuff is working but there are still some general pathfinding problems. Vehicles have problems over long distances, sometimes get stuck in a loop crashing into a tree or rock. I think some of it can be improved by tweaking some values, but it's difficult to detect problems where it's stuck but not fully stopped, and also difficult to determine a different behaviour that will help in most situations and not just make it worse. Overall it seems a bit better than the 0.15 version but it's highly subjective and environment dependant. Feedback on where the pathfinding is better or worse than the 0.15 versions would be useful.
For the current (latest) version you have allowed us to play, I have noticed that vehicles do not want to complete a long pathfind, somewhere over 30 tiles. It seems they go so far, and then stop and cancel the remaining path to the final target destination. then they jus sit until I command them again. Sometimes, I am moving them a couple times in short distances just to get them to where I want them. Have you been improving this? Do you need a save file?

User avatar
Earendel
Filter Inserter
Filter Inserter
Posts: 691
Joined: Sun Nov 23, 2014 11:57 am
Contact:

Re: [MOD 0.14] AAI Programmable Vehicles

Post by Earendel »

RocketManChronicles wrote:
Earendel wrote:I plan to release the 0.16 versions tomorrow morning. Most stuff is working but there are still some general pathfinding problems. Vehicles have problems over long distances, sometimes get stuck in a loop crashing into a tree or rock. I think some of it can be improved by tweaking some values, but it's difficult to detect problems where it's stuck but not fully stopped, and also difficult to determine a different behaviour that will help in most situations and not just make it worse. Overall it seems a bit better than the 0.15 version but it's highly subjective and environment dependant. Feedback on where the pathfinding is better or worse than the 0.15 versions would be useful.
For the current (latest) version you have allowed us to play, I have noticed that vehicles do not want to complete a long pathfind, somewhere over 30 tiles. It seems they go so far, and then stop and cancel the remaining path to the final target destination. then they jus sit until I command them again. Sometimes, I am moving them a couple times in short distances just to get them to where I want them. Have you been improving this? Do you need a save file?
Hmmm. So pathfinding is done with an invisible biter. Sometimes the biter goes where you tell it, but sometimes if the path fails for whatever reason, it does that wandering in circles thing that biters do. Previously there was no way to tell which one it was doing, so if it looked like the path the biter followed is not useful then it stops and tries a new path. I think that's what is happening, the path is valid but the anti-wander code is resetting it. The way things work is a bit different now because the biter is much faster and the full path gets saved ahead of time so I should be able to fix that.

RocketManChronicles
Filter Inserter
Filter Inserter
Posts: 334
Joined: Mon Aug 01, 2016 2:38 pm
Contact:

Re: [MOD 0.14] AAI Programmable Vehicles

Post by RocketManChronicles »

Earendel wrote:
RocketManChronicles wrote:
Earendel wrote:I plan to release the 0.16 versions tomorrow morning. Most stuff is working but there are still some general pathfinding problems. Vehicles have problems over long distances, sometimes get stuck in a loop crashing into a tree or rock. I think some of it can be improved by tweaking some values, but it's difficult to detect problems where it's stuck but not fully stopped, and also difficult to determine a different behaviour that will help in most situations and not just make it worse. Overall it seems a bit better than the 0.15 version but it's highly subjective and environment dependant. Feedback on where the pathfinding is better or worse than the 0.15 versions would be useful.
For the current (latest) version you have allowed us to play, I have noticed that vehicles do not want to complete a long pathfind, somewhere over 30 tiles. It seems they go so far, and then stop and cancel the remaining path to the final target destination. then they jus sit until I command them again. Sometimes, I am moving them a couple times in short distances just to get them to where I want them. Have you been improving this? Do you need a save file?
Hmmm. So pathfinding is done with an invisible biter. Sometimes the biter goes where you tell it, but sometimes if the path fails for whatever reason, it does that wandering in circles thing that biters do. Previously there was no way to tell which one it was doing, so if it looked like the path the biter followed is not useful then it stops and tries a new path. I think that's what is happening, the path is valid but the anti-wander code is resetting it. The way things work is a bit different now because the biter is much faster and the full path gets saved ahead of time so I should be able to fix that.
You know, now that I think about it a little after reading this, I think the vehicles were near an obstacle (not blocked by it), usually a rock, a cliff, or a building. Does the code fail the pathfinding if a potential solution is "clipped" by the hitbox of something like that? When I am playing tonight, I will try to keep an eye on them is see if I can see what they are trying to do. This gives me some ideas to experiment with just to see what it is doing.

Mobius1
Fast Inserter
Fast Inserter
Posts: 191
Joined: Thu Feb 09, 2017 12:05 am
Contact:

Re: [MOD 0.14] AAI Programmable Vehicles

Post by Mobius1 »

Hey White Tiger, wassup?
What about Rampant AI? Can you use his AI code to try to improve pathfinding on AAI?

000Paulo000
Manual Inserter
Manual Inserter
Posts: 3
Joined: Sat Feb 03, 2018 3:31 am
Contact:

Re: [MOD 0.14] AAI Programmable Vehicles

Post by 000Paulo000 »

Hello!
Does anyone have any help for this?

Error while running event RoboTank::on_tick (ID 0)
LuaEntity API call when LuaEntity was invalid.
stack traceback:
__RoboTank__/control.lua:304: in function 'find_commander_controller'
__RoboTank__/control.lua:887: in function 'refresh_commander'
__RoboTank__/control.lua:990: in function 'update_robotank_force_on_tick'
__RoboTank__/control.lua:1104: in function <__RoboTank__/control.lua:1088>

happens when I use the control and I send a vehicle to anywhere
thanks!

User avatar
Earendel
Filter Inserter
Filter Inserter
Posts: 691
Joined: Sun Nov 23, 2014 11:57 am
Contact:

Re: [MOD 0.14] AAI Programmable Vehicles

Post by Earendel »

000Paulo000 wrote:Hello!
Does anyone have any help for this?

Error while running event RoboTank::on_tick (ID 0)
LuaEntity API call when LuaEntity was invalid.
stack traceback:
__RoboTank__/control.lua:304: in function 'find_commander_controller'
__RoboTank__/control.lua:887: in function 'refresh_commander'
__RoboTank__/control.lua:990: in function 'update_robotank_force_on_tick'
__RoboTank__/control.lua:1104: in function <__RoboTank__/control.lua:1088>

happens when I use the control and I send a vehicle to anywhere
thanks!
I don't think the two mods will be compatible.

If you want a tank to follow you select it with the remote controller and alt-click yourself. If you do that with multiple vehicles they follow you into a circle formation.

000Paulo000
Manual Inserter
Manual Inserter
Posts: 3
Joined: Sat Feb 03, 2018 3:31 am
Contact:

Re: [MOD 0.16] AAI Programmable Vehicles

Post by 000Paulo000 »

I tried and it happened the same.
any vehicle that I use the remote control to move or follow me happens this error.
I'll try to disable all the mods and only run with the essentials

000Paulo000
Manual Inserter
Manual Inserter
Posts: 3
Joined: Sat Feb 03, 2018 3:31 am
Contact:

Re: [MOD 0.14] AAI Programmable Vehicles

Post by 000Paulo000 »

First of all thank you for your attention.
I disabled all the mods and enabled them one at a time.
It really was a conflict between mods.
Thanks again!
your mods are spectacular

Ratzap
Filter Inserter
Filter Inserter
Posts: 371
Joined: Sun Aug 16, 2015 11:15 pm
Contact:

Re: [MOD 0.14] AAI Programmable Vehicles

Post by Ratzap »

My AAI save from v15 still has 3 files not updated that I think were part of the set:

data-raw-prototypes
detached-gun-sounds
off-grid-effects

Are they part of the AAI set and still needed?

Post Reply

Return to “Mods”

Who is online

Users browsing this forum: No registered users