[MOD 0.16] Vehicle Wagon 1.2.5

Topics and discussion about specific mods
Phasma Felis
Inserter
Inserter
Posts: 33
Joined: Wed Feb 25, 2015 1:02 am
Contact:

Re: [MOD 0.15] Vehicle Wagon 1.1.0

Post by Phasma Felis » Fri May 19, 2017 11:11 pm

Supercheese wrote:Thanks for the contributions guys, version 1.1.0 is now released. A new feature is blinking arrows that indicate which vehicle you have selected for winching -- try it out and see! :)
Awesome! I'll try it immediately.
Additional contributions from: Mooncat & The_Destroyer.
Hey! I helped too, a bit. :)

Supercheese
Filter Inserter
Filter Inserter
Posts: 835
Joined: Mon Sep 14, 2015 7:40 am
Contact:

Re: [MOD 0.15] Vehicle Wagon 1.1.0

Post by Supercheese » Sat May 20, 2017 1:16 am

Phasma Felis wrote:Hey! I helped too, a bit. :)
Right you are, sorry I missed ya; I've added you in now.

dgw
Fast Inserter
Fast Inserter
Posts: 189
Joined: Tue Apr 12, 2016 7:06 pm
Contact:

Re: [MOD 0.15] Vehicle Wagon 1.1.0

Post by dgw » Sat Jun 17, 2017 1:15 am

So, this seems as good a place as any to ask about some odd behavior I've started getting today. (Besides the odd-looking graphics when a vehicle wagon is in any orientation except E-W—you likely know about that!)

I added Vehicle Wagon to my save earlier this week and played around with it, putting tanks/cars on and off a new train I built for the purpose. I put the Winch item in a dedicated hotbar slot.

Today, I've lost my Winch twice after removing vehicles from the train. Since I hadn't ever lost a Winch just from using it until today, I went looking for talk about the issue. Couldn't find anything, obviously.

Is the Winch meant to be consumable? I get the impression that it's not. This could be a mod conflict, so my mod-list.json is attached. If you'd like my save for debugging, I can get that uploaded too (just avoiding clutter on the forum servers unless it's really needed).
Attachments
mod-list.json
Mod List for save where Winch is lost upon removing a vehicle from the wagon.
(2.76 KiB) Downloaded 52 times

Phasma Felis
Inserter
Inserter
Posts: 33
Joined: Wed Feb 25, 2015 1:02 am
Contact:

Re: [MOD 0.15] Vehicle Wagon 1.1.0

Post by Phasma Felis » Mon Jun 19, 2017 4:54 am

I've noticed that it sometimes goes to the first available hotbar slot, rather than the one I designated for it, after use. Haven't had it vanish, though.

I wonder if it would make sense to ditch the winch item entirely, and make it a button in the UI window for the vehicle wagon.

Oh, I have a minor bug report: when winching/unwinching a tank, the currently selected weapon is reset (to the cannon), and with the Vehicle Equipment Grid mod, the vehicle's "Enable logistics while moving" setting is reset as well.

leoch
Fast Inserter
Fast Inserter
Posts: 124
Joined: Fri Dec 16, 2016 9:37 pm
Contact:

Re: [MOD 0.15] Vehicle Wagon 1.1.0

Post by leoch » Fri Jun 23, 2017 1:52 pm

Bug report against Factorio

(But I don't know if it's better to work around this issue in the mod. I'm fairly sure the engine update is what broke the mod for me since nothing else changed at the time.)

Edit: closed, because mods are supposed to work with the game as-is (or report issues with the modding API.)

dgw
Fast Inserter
Fast Inserter
Posts: 189
Joined: Tue Apr 12, 2016 7:06 pm
Contact:

Re: [MOD 0.15] Vehicle Wagon 1.1.0

Post by dgw » Fri Jun 23, 2017 10:55 pm

Well, that explains why this quit working on my save. I was able to winch both vehicles off of the vehicle wagons, but not put them back on. Since I thus had an empty train, I just recycled the parts and removed the mod for now.

I don't remember seeing much in the recent Factorio change notes that would affect mods in this manner, but I'm also almost completely ignorant of how modding works in this game, so…

Supercheese
Filter Inserter
Filter Inserter
Posts: 835
Joined: Mon Sep 14, 2015 7:40 am
Contact:

Re: [MOD 0.15] Vehicle Wagon 1.1.1

Post by Supercheese » Sun Jun 25, 2017 2:15 am

I believe Vehicle Wagon had the same issue as Orbital Ion Cannon's disappearing targeting device, so I've uploaded v1.1.1 which should hopefully fix the disappearing winch issues.

dgw
Fast Inserter
Fast Inserter
Posts: 189
Joined: Tue Apr 12, 2016 7:06 pm
Contact:

Re: [MOD 0.15] Vehicle Wagon 1.1.1

Post by dgw » Sun Jun 25, 2017 6:32 am

Cheers, Supercheese. I'm glad I didn't start using OIC until after that bug was fixed…

Any thoughts on the breakage of winching things onto the vehicle wagons in 0.15.22/23?

Supercheese
Filter Inserter
Filter Inserter
Posts: 835
Joined: Mon Sep 14, 2015 7:40 am
Contact:

Re: [MOD 0.15] Vehicle Wagon 1.1.1

Post by Supercheese » Sun Jun 25, 2017 6:22 pm

dgw wrote:Any thoughts on the breakage of winching things onto the vehicle wagons in 0.15.22/23?
Hmm, is it still broken using Vehicle Wagon v1.1.1? My testing didn't reveal bugs, but it was a fairly limited test.

dgw
Fast Inserter
Fast Inserter
Posts: 189
Joined: Tue Apr 12, 2016 7:06 pm
Contact:

Re: [MOD 0.15] Vehicle Wagon 1.1.1

Post by dgw » Sun Jun 25, 2017 9:14 pm

Vehicle Wagon v1.1.1 works for me too; was just curious if any changes had to be made to fix winching. Guess my question was kinda ambiguous, sorry. :)

Edit: It's a little thing, but how annoying would it be to make it so Q (the object pipette tool) picks up an empty vehicle wagon from inventory even if the cursor is over a loaded wagon? Right now, trying to pipette a loaded wagon just gives an error sound even if I have a vehicle wagon in my pocket. (Possibly very annoying or impossible… I haven't found any events in the API that fire when a player doesn't have an item, which would be the easiest way to handle this.)

Ruben_NL
Burner Inserter
Burner Inserter
Posts: 8
Joined: Sun May 14, 2017 2:02 pm
Contact:

Re: [MOD 0.15] Vehicle Wagon 1.1.1

Post by Ruben_NL » Mon Jun 26, 2017 11:25 am

Hey guys, i think i have found a "bug".
when i put an car/tank on my wagon, and remove it, the fuel bar is 0.

Ruben_NL
Burner Inserter
Burner Inserter
Posts: 8
Joined: Sun May 14, 2017 2:02 pm
Contact:

Re: [MOD 0.15] Vehicle Wagon 1.1.1

Post by Ruben_NL » Thu Jun 29, 2017 12:46 pm

hmmm found another "bug". when using the mods "aircraft" and "LiftoffEnhanced", and loading an plane on the car, it works. it leaves a scrap of the plane on the place i loaded it, but thats OK.
when i unload it, it gives an error.

dgw
Fast Inserter
Fast Inserter
Posts: 189
Joined: Tue Apr 12, 2016 7:06 pm
Contact:

Re: [MOD 0.15] Vehicle Wagon 1.1.1

Post by dgw » Thu Jun 29, 2017 1:28 pm

Good thing I haven't tried to put any aircraft on my train yet… I guess. Aircraft strikes me as a kludge wrapped in a hack nested inside a bunch of overrides, though, so… I'm not going to be surprised at anything that breaks when using Aircraft with anything else, haha. (In seriousness, airplanes don't collide with anything because of one line in the entity definition, an empty collision_mask. I went looking for how it was implemented before making this joke, but I'm going to leave it.)

User avatar
Optera
Smart Inserter
Smart Inserter
Posts: 2275
Joined: Sat Jun 11, 2016 6:41 am
Contact:

Re: [MOD 0.15] Vehicle Wagon 1.1.1

Post by Optera » Thu Jun 29, 2017 1:36 pm

The Description clearly states
Of course, you aren't allowed to load your aircraft onto wagons, as there'd be no point!

Ruben_NL
Burner Inserter
Burner Inserter
Posts: 8
Joined: Sun May 14, 2017 2:02 pm
Contact:

Re: [MOD 0.15] Vehicle Wagon 1.1.1

Post by Ruben_NL » Thu Jun 29, 2017 4:58 pm

Optera wrote:The Description clearly states
Of course, you aren't allowed to load your aircraft onto wagons, as there'd be no point!
But, it is possible, and gives an error. but i think its usefull, i thought about:

having a train with all my stuff, including an plane, to fast get some items that i forgot to an outpost.

dgw
Fast Inserter
Fast Inserter
Posts: 189
Joined: Tue Apr 12, 2016 7:06 pm
Contact:

Re: [MOD 0.15] Vehicle Wagon 1.1.1

Post by dgw » Thu Jun 29, 2017 6:44 pm

Ruben_NL wrote:
Optera wrote:The Description clearly states
Of course, you aren't allowed to load your aircraft onto wagons, as there'd be no point!
But, it is possible, and gives an error.
Should the mod try to catch attempts to put aircraft on the vehicle wagon? Possibly.

Supercheese
Filter Inserter
Filter Inserter
Posts: 835
Joined: Mon Sep 14, 2015 7:40 am
Contact:

Re: [MOD 0.15] Vehicle Wagon 1.1.1

Post by Supercheese » Thu Jun 29, 2017 9:21 pm

Seems like Vehicle Wagon is false-positive-ing on the "cargo-plane" entity, thinking it's a "car"-type since it matches the string pattern (just a check if "car" is present in the vehicle.name). I'll have this fixed for the next version.

Supercheese
Filter Inserter
Filter Inserter
Posts: 835
Joined: Mon Sep 14, 2015 7:40 am
Contact:

Re: [MOD 0.15] Vehicle Wagon 1.1.2

Post by Supercheese » Sat Jul 08, 2017 6:29 am

New update to fix this false positive issue -- but also a superb new idea to add support for vehicles that cannot be automatically identified!

These new tarp wagons should cover most all previously-unidentifiable vehicles. Of course there is currently no feedback as to what's under the tarp, but it's definitely better than being unable to load the vehicles at all. Huge thanks to Brant Wedel for implementing this new feature.

Give it a test and see how it works for ya!

User avatar
SuicidalKid
Filter Inserter
Filter Inserter
Posts: 253
Joined: Thu Jan 29, 2015 9:58 pm
Contact:

Re: [MOD 0.15] Vehicle Wagon 1.1.2

Post by SuicidalKid » Mon Jul 17, 2017 4:54 am

Supercheese wrote:New update to fix this false positive issue -- but also a superb new idea to add support for vehicles that cannot be automatically identified!

These new tarp wagons should cover most all previously-unidentifiable vehicles. Of course there is currently no feedback as to what's under the tarp, but it's definitely better than being unable to load the vehicles at all. Huge thanks to Brant Wedel for implementing this new feature.

Give it a test and see how it works for ya!
I'm very excited for this, it seems to be a great solution for the problem we faced with this and aircraft a while ago.
I have no idea what I'm doing.

User avatar
KNOWFEAR1337
Burner Inserter
Burner Inserter
Posts: 18
Joined: Mon Jul 13, 2015 1:10 am
Contact:

Re: [MOD 0.15] Vehicle Wagon 1.1.2

Post by KNOWFEAR1337 » Sun Sep 17, 2017 8:10 pm

not been playing for a while now because i was a bit burned out and there were a few mods that just didn't quite mesh properly. and i was wondering if one i didn't think of like this one could help me out with my problem. and that is power; vehicle grid power / charging.

i have a couple different mods that all work perfectly fine but neither of the dev's seem too interested in helping resolve it. i was so happy when i tested that loading and unloading didn't wipe the grid in my car. but it did wipe out the power. i dont know if there's any way you can fix this or change it at all but it would be fantastic. i guess it normally isn't an issue when you have vanilla style fusion reactors but i'm using modular armor and those reactors use fuel and both the wireless charging mods I've found dont charge the vehicles T_T

Post Reply

Return to “Mods”

Who is online

Users browsing this forum: No registered users