[MOD 0.12.x] Autofill

Topics and discussion about specific mods
Kibaru
Manual Inserter
Manual Inserter
Posts: 2
Joined: Sun Feb 11, 2018 11:41 am
Contact:

Re: [MOD 0.12.x] Autofill

Post by Kibaru » Sat Feb 24, 2018 10:19 am

I noticed that if I create a blueprint without ammo in it, and then placing the blueprint the turret will "request" ammo. I guess thats because of auto-fill also taking care of stuff which is being placed by bots/blueprints? Can that be changed so it only autofills when I as the player place something?

Slayn25
Fast Inserter
Fast Inserter
Posts: 123
Joined: Sun May 15, 2016 5:59 pm
Contact:

Re: [MOD 0.12.x] Autofill

Post by Slayn25 » Tue Mar 06, 2018 11:44 pm

Error while running on_load: __autofill__/stdlib/event/event.lua:163: __autofill__/autofill/sets.lua:78: attempt to index field '_changes' (a nil value)

Xillian112
Burner Inserter
Burner Inserter
Posts: 12
Joined: Mon Apr 18, 2016 6:36 pm
Contact:

Re: [MOD 0.12.x] Autofill

Post by Xillian112 » Sun Mar 18, 2018 6:48 am

Slayn25 wrote:Error while running on_load: __autofill__/stdlib/event/event.lua:163: __autofill__/autofill/sets.lua:78: attempt to index field '_changes' (a nil value)
Same error here...

Quazar
Long Handed Inserter
Long Handed Inserter
Posts: 51
Joined: Sat Mar 26, 2016 4:12 pm
Contact:

Re: [MOD 0.12.x] Autofill

Post by Quazar » Tue Mar 20, 2018 12:58 pm

It seems broken. I'm running 2.0.1 with Factorio 0.16.31 (happy to provide more details)

Code: Select all

  21.099 Script @__autofill__/stdlib/event/event.lua:160: __autofill__/autofill/sets.lua:73: attempt to index field 'forces' (a nil value)
  21.192 Script @__autofill__/stdlib/event/event.lua:160: __autofill__/changes.lua:34: bad argument #0 to 'log' (Wrong number of arguments.)
  21.193 Script @__autofill__/stdlib/event/event.lua:160: __autofill__/autofill/sets.lua:73: attempt to index field 'forces' (a nil value)
 132.908 Script @__autofill__/stdlib/event/event.lua:160: __autofill__/autofill/autofill.lua:51: attempt to index local 'pdata' (a nil value)
I consider this mod non-optional, so good. Please let us know, thanks!

Lastmerlin
Long Handed Inserter
Long Handed Inserter
Posts: 56
Joined: Thu Jun 16, 2016 11:02 am
Contact:

Re: [MOD 0.12.x] Autofill

Post by Lastmerlin » Fri Apr 06, 2018 7:26 pm

Any progress in this regard? Currently, this is the reason that all my maps from 0.15 are not loading anymore. For some reason, using the mod with a fresh map is ok.

npuldon
Fast Inserter
Fast Inserter
Posts: 139
Joined: Thu Dec 08, 2016 8:36 am
Contact:

Re: [MOD 0.12.x] Autofill

Post by npuldon » Sun Apr 15, 2018 3:30 pm

Is it possible to toggle the "request item" addition that happens when you blueprint stuff. It's really annoying when burner inserters and stone furnace have the blue request item icon on them during blue prints. Esepecially the burner inserters since the request icon takes up the whole entity and you can't click on the inserter to fill it.


Also, how do I make it so that autofill defaults to the highest energy dense fuel I have in my inventory instead of the lowest. For instance, if I have raw wood and coal in my inventory, raw wood is autofilled into stone furnaces instead of coal. I would like the opposite to be true.

Thanks for your help

User avatar
Omnifarious
Fast Inserter
Fast Inserter
Posts: 190
Joined: Wed Jul 26, 2017 3:24 pm
Contact:

Re: [MOD 0.12.x] Autofill

Post by Omnifarious » Tue May 01, 2018 7:29 pm

Quazar wrote:It seems broken. I'm running 2.0.1 with Factorio 0.16.31 (happy to provide more details)

Code: Select all

  21.099 Script @__autofill__/stdlib/event/event.lua:160: __autofill__/autofill/sets.lua:73: attempt to index field 'forces' (a nil value)
  21.192 Script @__autofill__/stdlib/event/event.lua:160: __autofill__/changes.lua:34: bad argument #0 to 'log' (Wrong number of arguments.)
  21.193 Script @__autofill__/stdlib/event/event.lua:160: __autofill__/autofill/sets.lua:73: attempt to index field 'forces' (a nil value)
 132.908 Script @__autofill__/stdlib/event/event.lua:160: __autofill__/autofill/autofill.lua:51: attempt to index local 'pdata' (a nil value)
I consider this mod non-optional, so good. Please let us know, thanks!
I'm getting the same error. Maybe I'll look into why it's happening. It doesn't seem like it would be hard to fix.

Salty Wagyu
Inserter
Inserter
Posts: 23
Joined: Thu Sep 21, 2017 10:37 am
Contact:

Re: [MOD 0.12.x] Autofill

Post by Salty Wagyu » Fri Jun 22, 2018 12:12 pm

Lots of errors when laying blueprints of beacons

__autofill__/autofill/autofill.lua:183: bad argument #2 to '__index' (string expected, got nil)
Also Nilaus gets it in his AngelBobs series at time 15:40 https://www.youtube.com/watch?v=QxRqZD7MDiA&t

nuhll
Filter Inserter
Filter Inserter
Posts: 820
Joined: Mon Apr 04, 2016 9:48 pm
Contact:

Re: [MOD 0.12.x] Autofill

Post by nuhll » Fri Jun 29, 2018 10:25 pm

6 Months no update, if you dont want to continue it, or dont know how to fix it. Ask for help or mark your mod as depraced, its not fun to try it 6 months later and still nothing changed. (but its okay if you dont have any time, but just tell us this, we wait for this)

Sarxis
Burner Inserter
Burner Inserter
Posts: 9
Joined: Sat Feb 24, 2018 2:21 pm
Contact:

Re: [MOD 0.12.x] Autofill

Post by Sarxis » Fri Jul 13, 2018 10:36 pm

Did anyone ever fill in the command line code for the Aircraft mod that is found here at Factorio mods?

Figured I'd ask before I tried tackling it myself. I'm not very good at this stuff! lol

nuhll
Filter Inserter
Filter Inserter
Posts: 820
Joined: Mon Apr 04, 2016 9:48 pm
Contact:

Re: [MOD 0.12.x] Autofill

Post by nuhll » Sat Jul 21, 2018 8:55 am

What you want to do?

There is another mod which does the exactly same like this here. Just use it.

Silden
Inserter
Inserter
Posts: 43
Joined: Thu Sep 10, 2015 3:59 pm
Contact:

Re: [MOD 0.12.x] Autofill

Post by Silden » Thu Nov 22, 2018 2:52 pm

Is there a way to get the mod to not take my Small Electric Poles in the early game? Every time I put down a Stone Furnace without coal in inventory, it's eating my poles which isn't good

User avatar
Oktokolo
Filter Inserter
Filter Inserter
Posts: 715
Joined: Wed Jul 12, 2017 5:45 pm
Contact:

Re: [MOD 0.12.x] Autofill

Post by Oktokolo » Thu Nov 22, 2018 5:14 pm

Silden wrote:
Thu Nov 22, 2018 2:52 pm
Is there a way to get the mod to not take my Small Electric Poles in the early game? Every time I put down a Stone Furnace without coal in inventory, it's eating my poles which isn't good
I stopped using Autofill for the same reason.
I like small power poles and use them a lot till end game as i rarely use medium poles and use power stations in solar/accumulator arrays only.

mrvn
Smart Inserter
Smart Inserter
Posts: 3897
Joined: Mon Sep 05, 2016 9:10 am
Contact:

Re: [MOD 0.12.x] Autofill

Post by mrvn » Fri Nov 23, 2018 9:52 am

Will it place nuclear fuel or wooden power poles into cars?

The first is bad because when you pick up the car 5 minutes later you waste 99% of the fuel. The later is an example of an item that has a fuel value but isn't really mend to be burned. Waste of good copper to burn it.

Post Reply

Return to “Mods”

Who is online

Users browsing this forum: kingarthur