[MOD 0.17.x] Natural Evolution - All things Alien!

Topics and discussion about specific mods
jessefjxm
Inserter
Inserter
Posts: 36
Joined: Wed Mar 14, 2018 1:45 am
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by jessefjxm » Sun Mar 18, 2018 12:40 am

This mod is pretty cool. Just wondering if it's possible to allow biters evolve infinitely. I feel biters are now toooo weak in may late bob+angel save :D

There's a mod Enhanced_Biters https://mods.factorio.com/mod/Enhanced_Biters that tries to infinitely enhance biter powers like this:

game.forces.enemy.set_ammo_damage_modifier("melee", 0.5 + (2 * scale + game.tick) / (2 * scale) )

Mylon
Filter Inserter
Filter Inserter
Posts: 369
Joined: Sun Oct 23, 2016 11:42 pm
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by Mylon » Sun Mar 18, 2018 1:48 am

jessefjxm wrote:This mod is pretty cool. Just wondering if it's possible to allow biters evolve infinitely. I feel biters are now toooo weak in may late bob+angel save :D

There's a mod Enhanced_Biters https://mods.factorio.com/mod/Enhanced_Biters that tries to infinitely enhance biter powers like this:

game.forces.enemy.set_ammo_damage_modifier("melee", 0.5 + (2 * scale + game.tick) / (2 * scale) )
That's only part of the story. Turrets also get weaker to simulate biters having more HP.

CaptainSmog
Manual Inserter
Manual Inserter
Posts: 4
Joined: Sun Mar 18, 2018 10:26 am
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by CaptainSmog » Sun Mar 18, 2018 10:34 am

In my current playthrough, I noticed that the biters just stopped expanding. They have lots and lots of room to expand (checked with F5) but they just don't. I then noticed that game.map_settings.enemy_expansion.enabled is being forced to false no matter what I do. Even if I set it to true, it gets reset to false a couple of minutes later (I checked with

Code: Select all

/c game.player.print(game.map_settings.enemy_expansion.enabled)
). I managed to get a few new bases built by forcing enemy_expansion.enabled to true constantly for 10 minutes, but obviously, this is not a sustainable state of affairs.

I suspect this mod to be the cause, but I have no idea really. Would this be intended behavior of this mod? If yes, what conditions do I need to fulfill to get biters to expand "naturally"?

orzelek
Smart Inserter
Smart Inserter
Posts: 3578
Joined: Fri Apr 03, 2015 10:20 am
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by orzelek » Sun Mar 18, 2018 11:29 am

CaptainSmog wrote:In my current playthrough, I noticed that the biters just stopped expanding. They have lots and lots of room to expand (checked with F5) but they just don't. I then noticed that game.map_settings.enemy_expansion.enabled is being forced to false no matter what I do. Even if I set it to true, it gets reset to false a couple of minutes later (I checked with

Code: Select all

/c game.player.print(game.map_settings.enemy_expansion.enabled)
). I managed to get a few new bases built by forcing enemy_expansion.enabled to true constantly for 10 minutes, but obviously, this is not a sustainable state of affairs.

I suspect this mod to be the cause, but I have no idea really. Would this be intended behavior of this mod? If yes, what conditions do I need to fulfill to get biters to expand "naturally"?
You can try to grab Evo GUI and use information about biter phase there to check. There is a paceful phase that disables expansion temporarly I think.

CaptainSmog
Manual Inserter
Manual Inserter
Posts: 4
Joined: Sun Mar 18, 2018 10:26 am
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by CaptainSmog » Sun Mar 18, 2018 12:29 pm

orzelek wrote:You can try to grab Evo GUI and use information about biter phase there to check. There is a peaceful phase that disables expansion temporarly I think.
Thanks for the quick reply - I already have Evo GUI and I don't know why I didn't bother to check if there's useful information in there. The additional NE fields sure are handy, but I'm not sure the info can help me find out what's going on. For one, I already played 72+ hours on this map, and the evolution factor is at 70%. I don't think there's supposed to be a peace time this late in the game, but maybe I just don't understand the mechanics correctly? The intro post doesn't seem to explain what the expansion phases do (are they the evolution states in EvoGUI?) - if there's some additional documentation somewhere you can point me to, please do.

Currently it says my evolution state is in phase 7, with a timer at 500 something seconds, going down steadily. I'll wait and see what happens when the timer hits 0 and report back.

CaptainSmog
Manual Inserter
Manual Inserter
Posts: 4
Joined: Sun Mar 18, 2018 10:26 am
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by CaptainSmog » Sun Mar 18, 2018 1:41 pm

CaptainSmog wrote:Currently it says my evolution state is in phase 7, with a timer at 500 something seconds, going down steadily. I'll wait and see what happens when the timer hits 0 and report back.
Ok, after it hit 0, the next phase said "peaceful", and sure enough, enemy_expansion.enabled was back to false. I think I noticed a new base too. I'll keep an eye on the phase indicator to confirm. But if this indeed how it's supposed to be, then the expansion is way too unaggressive for my liking... is there a way to tweak this without having to mess around with the lua files (so that the changes don't get lost after mod updates)?

/update The next non-peaceful phase still didn't return enemy_expansion.enabled back to true. Could this be a bug? Or are those phases not supposed to have anything to do with expansion after all?
I guess at least I now know exactly when the setting will be reset, so this is an acceptable workaround for now...

orzelek
Smart Inserter
Smart Inserter
Posts: 3578
Joined: Fri Apr 03, 2015 10:20 am
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by orzelek » Sun Mar 18, 2018 1:56 pm

CaptainSmog wrote:
CaptainSmog wrote:Currently it says my evolution state is in phase 7, with a timer at 500 something seconds, going down steadily. I'll wait and see what happens when the timer hits 0 and report back.
Ok, after it hit 0, the next phase said "peaceful", and sure enough, enemy_expansion.enabled was back to false. I think I noticed a new base too. I'll keep an eye on the phase indicator to confirm. But if this indeed how it's supposed to be, then the expansion is way too unaggressive for my liking... is there a way to tweak this without having to mess around with the lua files (so that the changes don't get lost after mod updates)?

/update The next non-peaceful phase still didn't return enemy_expansion.enabled back to true. Could this be a bug? Or are those phases not supposed to have anything to do with expansion after all?
I guess at least I now know exactly when the setting will be reset, so this is an acceptable workaround for now...
It would look like a bug for me.

I'd expect it to enable expansion as soon as you go out of paceful phase.
I made a quick test and it seems to work correctly for me.

You can extract the mod and set QC_Mod to true at start of control.lua. It will print then all the decisions to console so you should see if something is off.
Also validate that you did not change the startup setting that allows mod to enable expansion.

TheSAguy
Smart Inserter
Smart Inserter
Posts: 1406
Joined: Mon Jan 13, 2014 6:17 pm
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by TheSAguy » Sun Mar 18, 2018 3:53 pm

orzelek wrote:
CaptainSmog wrote:
CaptainSmog wrote:Currently it says my evolution state is in phase 7, with a timer at 500 something seconds, going down steadily. I'll wait and see what happens when the timer hits 0 and report back.
Ok, after it hit 0, the next phase said "peaceful", and sure enough, enemy_expansion.enabled was back to false. I think I noticed a new base too. I'll keep an eye on the phase indicator to confirm. But if this indeed how it's supposed to be, then the expansion is way too unaggressive for my liking... is there a way to tweak this without having to mess around with the lua files (so that the changes don't get lost after mod updates)?

/update The next non-peaceful phase still didn't return enemy_expansion.enabled back to true. Could this be a bug? Or are those phases not supposed to have anything to do with expansion after all?
I guess at least I now know exactly when the setting will be reset, so this is an acceptable workaround for now...
It would look like a bug for me.

I'd expect it to enable expansion as soon as you go out of paceful phase.
I made a quick test and it seems to work correctly for me.

You can extract the mod and set QC_Mod to true at start of control.lua. It will print then all the decisions to console so you should see if something is off.
Also validate that you did not change the startup setting that allows mod to enable expansion.
Captain, can you send me a save?
Should be expanding after the peace phase

CaptainSmog
Manual Inserter
Manual Inserter
Posts: 4
Joined: Sun Mar 18, 2018 10:26 am
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by CaptainSmog » Sun Mar 18, 2018 4:14 pm

orzelek wrote:Also validate that you did not change the startup setting that allows mod to enable expansion.
That seems to have been it :roll: This setting was the first thing I checked - it was enabled when I noticed expansion being turned off. I disabled the option and enabled expansion manually, and that did not appear to change anything (expansion was still being forced off during phase change - I now assume it was into a peaceful phase). And of course, I forgot to turn it back on... Now, it seems expansion is always being re-enabled when transitioning to a non-peaceful phase again, so I think it's solved.

This still doesn't really explain the very, very prolonged lack of any and all expansion activity by the biters that got me to dig deeper in the first place. I was barely producing any pollution during that time, maybe that had something to do with it. I set QC_Mod to true for now as you recommended and I'll see if I notice anything else. Thanks for the efficient help!
TheSAguy wrote:Captain, can you send me a save?
Should be expanding after the peace phase
Do you still want the save despite the above? It's very mod-heavy and it might now not be worth the trouble anymore... the first couple of outputs from QC_Mod that I saw looked fine too. Although the negative building coefficient seemed peculiar to me, but I'm not an expert on the expansion formulas or anything.

jape3
Burner Inserter
Burner Inserter
Posts: 9
Joined: Tue Aug 15, 2017 10:31 pm
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by jape3 » Mon Mar 19, 2018 11:14 am

Yesterday evening we continued our multiplayer game with Natural evolution. 8.0.2 worked out of the box without desyncs (continuing existing game), so it looks like the new version fixed the issue. Thanks! :)

wibblewobble
Manual Inserter
Manual Inserter
Posts: 4
Joined: Thu May 10, 2018 12:47 am
Contact:

UPS bug with NE Expansion?

Post by wibblewobble » Thu May 10, 2018 1:05 am

First off, thanks for making such a great mod. It adds a lot to the game, and we have so much fun playing with all the new alien features. We enjoy a more "base defense" style of play. I play on enemies set to max everything.

I have identified a repeatable action with the NE Expansion mod which instantly lowers UPS from 60 down to 44. This only occurs when "Harder End-game" is checked." If I uncheck that setting then there is no drop in UPS. When I place the rocket silo building, I get the notification that a large sound has occurred and enemies will attack. After this message, UPS drops from 60 down to 44. I look all around the map to see what might have occurred and there is nothing. No attacks, no changes that I can observe. If I remove the rocket silo building, then UPS goes back up to 60. If I place it down again, the message repeats and UPS drops. I can place two rocket silos, and the message repeats twice and UPS goes to 44. I can place and pickup the rocket silo and the UPS goes up and down.

I can't figure out what is going on in the game that is causing it to slow down so drastically. Maybe more enemies spawned, but it's hard to tell. I let the game run for 10 minutes, and it is still running in a degraded state with no observable increase in attacks.

Thoughts? Any idea what is causing it?

Mod List:
Bob's:
Adjustable Inserters
Bob's Enemies
Bob's Functions Library mod
Bob's Greenhouse mod
Bob's Logistics mod
Bob's Mining
Bob's Power
Bob's Tech
Bob'e Vehicle Equipment
Bob's Warfare
Bob's Assembly
Bob's Classes
Bob's Inserters

EvoGUI
Natural Evolution Buildings
Natural Evolution Enemies
Natural Evolution Expansion
Swarm
Robot Army
Teleportation
Warehousing
Large Chests
Factorissimo 2
Bottleneck
Additional Turrets
Orbital Ion Cannon
Scattergun Turret
Reinforced Walls
Rampant ---- this mod is currently Disabled because it appeared to cause multiplayer lag
Aircraft
Autofill
Force Fields
Helicopters
Miniloader
Nanobots
Ultimate Belts
Upgrade Planner

TheSAguy
Smart Inserter
Smart Inserter
Posts: 1406
Joined: Mon Jan 13, 2014 6:17 pm
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by TheSAguy » Thu May 10, 2018 1:47 pm

Thanks for the report Wibblewobble.
Could you please send me a save?

The model should be looking for biters and send the to attack, but that should maybe cause a temp lag, not persistent.

wibblewobble
Manual Inserter
Manual Inserter
Posts: 4
Joined: Thu May 10, 2018 12:47 am
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by wibblewobble » Fri May 11, 2018 1:58 pm

Thank you for taking the time to troubleshoot this. Here is a link to the save and mod list: https://drive.google.com/open?id=1SrFFx ... LyCKGOQcu3

The Harder End Game mod setting probably needs to be turned on. I parked the guy right next to the rocket silos.

User avatar
Xagros
Inserter
Inserter
Posts: 39
Joined: Thu Jul 20, 2017 4:11 pm
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by Xagros » Tue May 22, 2018 7:11 am

Hello. I have found a bug. I do not know why, but it happened while I was defending the wall. Probably the latest version of the trigger issue.
Attachments
_autosave3.zip
(6.95 MiB) Downloaded 15 times
0000000.PNG
0000000.PNG (302.14 KiB) Viewed 1685 times
ImageImage

TheSAguy
Smart Inserter
Smart Inserter
Posts: 1406
Joined: Mon Jan 13, 2014 6:17 pm
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by TheSAguy » Tue May 22, 2018 3:57 pm

Xagros wrote:Hello. I have found a bug. I do not know why, but it happened while I was defending the wall. Probably the latest version of the trigger issue.
Xagros,
I'm getting this error when loading the save:
Image

Can you tell me what you were doing when the error happened?
I started a new game with your mods and it all seems to work. I added a call to have biters attack when you bomb cliffs. I tested it in a new game and it worked.

User avatar
Xagros
Inserter
Inserter
Posts: 39
Joined: Thu Jul 20, 2017 4:11 pm
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by Xagros » Wed May 23, 2018 5:24 am

TheSAguy wrote: Can you tell me what you were doing when the error happened?
I started a new game with your mods and it all seems to work. I added a call to have biters attack when you bomb cliffs. I tested it in a new game and it worked.
The above window occurs when the mod setting is different. And the bug I found is in the multiplay game, so I do not know exactly the cause. If the bug occurs again, I will extract the log and send it to you.
ImageImage

TheSAguy
Smart Inserter
Smart Inserter
Posts: 1406
Joined: Mon Jan 13, 2014 6:17 pm
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by TheSAguy » Wed May 23, 2018 6:33 pm

Xagros wrote:Hello. I have found a bug. I do not know why, but it happened while I was defending the wall. Probably the latest version of the trigger issue.
Please give 8.1.4 a go and let me know if this fixes the issue.

TheSAguy
Smart Inserter
Smart Inserter
Posts: 1406
Joined: Mon Jan 13, 2014 6:17 pm
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by TheSAguy » Wed Jul 18, 2018 9:04 pm

Released Version 9.0.0 of NE Enemies.

Would like to get some feedback on the new enemies and balancing feedback.
New-Stuff

orzelek
Smart Inserter
Smart Inserter
Posts: 3578
Joined: Fri Apr 03, 2015 10:20 am
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by orzelek » Wed Jul 18, 2018 9:41 pm

Two fast comments:
1. Those biters/spitters might be to big - they get pixellated. Maybe scaling option to make increase smaller.
2. They fact that you added option for every spawner... that will be a pain to implement in RSO :(

TheSAguy
Smart Inserter
Smart Inserter
Posts: 1406
Joined: Mon Jan 13, 2014 6:17 pm
Contact:

Re: [MOD 0.16.x] Natural Evolution - All things Alien!

Post by TheSAguy » Wed Jul 18, 2018 10:47 pm

orzelek wrote:Two fast comments:
1. Those biters/spitters might be to big - they get pixellated. Maybe scaling option to make increase smaller.

I'm currently scaling from 0.25 to 2. The Vanilla behemoth biter is at 1.2
I guess I could reduce my scaling, maybe to 1.5. Anyone have high def biter graphics ?!
orzelek wrote: 2. They fact that you added option for every spawner... that will be a pain to implement in RSO :(
Sorry..... create a function and call it 5x :lol:

Post Reply

Return to “Mods”

Who is online

Users browsing this forum: dorfl, nosports