Bugs & FAQ

Infinite Ores, Refining, Ore Processing ...

Moderator: Arch666Angel

Pluranium_Alloy
Manual Inserter
Manual Inserter
Posts: 4
Joined: Sun Oct 06, 2019 8:35 pm
Contact:

Re: Bugs & FAQ

Post by Pluranium_Alloy »

Sworn wrote:
Mon Jan 10, 2022 11:40 am
Pluranium_Alloy wrote:
Sun Jan 09, 2022 7:30 pm
The recipe "Advanced deuterium fuel cell reprocessing" is actually impossible to craft as the centrifuge has no fluid input. Is this a bug or intended?
yep, seems to be missing the assemble target in the recipe :?
According to the files, the recipe is of the "centrifuging" category, which is correct. Furthermore, in the image, I had clicked on the centrifuge to bring up the GUI, indicating that it is successfully registering that the centrifuge is the correct machine, however, as i stated in my previous post, the centrifuge has no fluid input. this renders it unable to use the recipe.

User avatar
valneq
Smart Inserter
Smart Inserter
Posts: 1138
Joined: Fri Jul 12, 2019 7:43 am
Contact:

Re: Bugs & FAQ

Post by valneq »

mr_andy51 wrote:
Mon Jan 03, 2022 12:23 pm
I've been having issues trying to use the search feature for Angel's Petrochemical Processing to look up Sodium Hydroxide. I had to use FNEI mod to find out that it's under Chlorine Processing 1 via Saline Water Electrolysis, but it won't pull this info up with vanilla search UI.
This is how the vanilla tech search feature works. It searches the tech name and the names of the unlocked recipes. I don't see how the mod authors can do anything about this.
I actually submitted this as a suggestion to the base game here:
viewtopic.php?p=495378#p495378

mr_andy51
Manual Inserter
Manual Inserter
Posts: 3
Joined: Mon Jan 03, 2022 12:12 pm
Contact:

Re: Bugs & FAQ

Post by mr_andy51 »

valneq wrote:
Mon Jan 10, 2022 9:20 pm
mr_andy51 wrote:
Mon Jan 03, 2022 12:23 pm
I've been having issues trying to use the search feature for Angel's Petrochemical Processing to look up Sodium Hydroxide. I had to use FNEI mod to find out that it's under Chlorine Processing 1 via Saline Water Electrolysis, but it won't pull this info up with vanilla search UI.
This is how the vanilla tech search feature works. It searches the tech name and the names of the unlocked recipes. I don't see how the mod authors can do anything about this.
I actually submitted this as a suggestion to the base game here:
viewtopic.php?p=495378#p495378
Sorry about that. Thought it was mod specific but saw that your post mentioned vanilla recipes containing the keyword. Either way, thank you for clearing that up for me.

steveas
Burner Inserter
Burner Inserter
Posts: 8
Joined: Sun Nov 30, 2014 8:39 pm
Contact:

Re: Bugs & FAQ

Post by steveas »

I have Py,angel,bob installed and i cant seem to make Hydrogen Peroxide Gas (no option in the "Filter mk1,2,3,4") and in FNEI its seems hidden/disabled any help to enable it as completely stuck

TIA

Steve

Sworn
Fast Inserter
Fast Inserter
Posts: 164
Joined: Sun Apr 03, 2016 8:10 pm
Contact:

Re: Bugs & FAQ

Post by Sworn »

Anyone got this weird error from angelsexploration?

Code: Select all

The mod Bob's Metals, Chemicals and Intermediates mod (1.1.3) caused a non-recoverable error.
Please report this error to the mod author.

Error while running event bobplates::on_configuration_changed
The mod Angel's Exploration (BETA) (0.3.13) caused a non-recoverable error.
Please report this error to the mod author.

Error while running event angelsexploration::on_technology_effects_reset (ID 102)
__angelsexploration__/src/tips-and-tricks-triggers.lua:50: attempt to index field '?' (a nil value)
stack traceback:
	__angelsexploration__/src/tips-and-tricks-triggers.lua:50: in function 'init_force_data'
	__angelsexploration__/src/tips-and-tricks-triggers.lua:120: in function 'on_tech_research_reset'
	__angelsexploration__/control.lua:89: in function <__angelsexploration__/control.lua:87>
stack traceback:
	[C]: in function 'reset_technology_effects'
	__bobplates__/control.lua:3: in function <__bobplates__/control.lua:1>

seems to have something to do when updating the ERM mods to the lasted version, but not really erm as root cause, cause when removing it from the mod list, it will run into the same error

current erm version if needed:
enemyracemanager_1.11.0
erm_toss_1.13.0
erm_marspeople_0.1.2
erm_redarmy_1.2.0
erm_zerg_1.13.1

also those were updated as well
Shortcuts-ick_1.1.22
vtk-deep-core-mining_2.9.1

save: https://drive.google.com/file/d/1GTz96l ... sp=sharing

Invisix
Manual Inserter
Manual Inserter
Posts: 4
Joined: Mon Oct 11, 2021 9:34 pm
Contact:

Re: Bugs & FAQ

Post by Invisix »

After updating my Angels mods and Clowns mods to latest i get this error

Playing with Angels, Bobs and Clowns all latest versions


It works to load the game after deleting the mod settings file

But when i sync my savegame with mods and settings i get the error.

If i load the savegame without syncing it seems that all tech overhaul and components overhaul items and buildings are deleted from the map
Attachments
20220119003224_1.jpg
20220119003224_1.jpg (122 KiB) Viewed 1709 times

User avatar
pezzawinkle
Fast Inserter
Fast Inserter
Posts: 110
Joined: Thu Jan 12, 2017 1:28 am
Contact:

Re: Bugs & FAQ

Post by pezzawinkle »

Can you please also add a save file, I don't know where to begin with tracking that error. The calls in the library are pretty innocuous and have quite a bit of sanity checking before hand.

Invisix
Manual Inserter
Manual Inserter
Posts: 4
Joined: Mon Oct 11, 2021 9:34 pm
Contact:

Re: Bugs & FAQ

Post by Invisix »

Change extension on mod settings to .dat, its not a zip just renamed.
Attachments
mod-settings.zip
(9.79 KiB) Downloaded 51 times
save.zip
(9.25 MiB) Downloaded 51 times

User avatar
pezzawinkle
Fast Inserter
Fast Inserter
Posts: 110
Joined: Thu Jan 12, 2017 1:28 am
Contact:

Re: Bugs & FAQ

Post by pezzawinkle »

thanks for that, im tracking it down now, it does appear that my suspicions are correct in that its a clowns science issue...

Ok, can you download the latest version (just uploaded now)... version 1.1.1 of clowns science. I am aware of the alternative packs being added to the default tab, the current state of clowns science is very much a work in progress, so bear with me.

Invisix
Manual Inserter
Manual Inserter
Posts: 4
Joined: Mon Oct 11, 2021 9:34 pm
Contact:

Re: Bugs & FAQ

Post by Invisix »

Fantasic, it works now!
Got a dialog with some changed science pack recipies but other than that everything seems to be the same, awesome work, thanks for quick fix! :)

TheyCallMeAmi
Manual Inserter
Manual Inserter
Posts: 1
Joined: Sun Mar 05, 2017 12:05 pm
Contact:

Re: Bugs & FAQ

Post by TheyCallMeAmi »

My game kicks me to the main menu whenever I try to load my save. Any idea what could be the issue?
Ask me for my save file if necessary.

The mod Bob's Metals, Chemicals and Intermediates mod (1.1.3) caused a non-recoverable error.
Please report this error to the mod author.

Error while running event bobplates::on_configuration_changed
The mod Angel's Exploration (BETA) (0.3.13) caused a non-recoverable error.
Please report this error to the mod author.

Error while running event angelsexploration::on_technology_effects_reset (ID 102)
__angelsexploration__/src/tips-and-tricks-triggers.lua:50: attempt to index field '?' (a nil value)
stack traceback:
__angelsexploration__/src/tips-and-tricks-triggers.lua:50: in function 'init_force_data'
__angelsexploration__/src/tips-and-tricks-triggers.lua:120: in function 'on_tech_research_reset'
__angelsexploration__/control.lua:89: in function <__angelsexploration__/control.lua:87>
stack traceback:
[C]: in function 'reset_technology_effects'
__bobplates__/control.lua:3: in function <__bobplates__/control.lua:1>

mageman1842
Burner Inserter
Burner Inserter
Posts: 10
Joined: Sun Aug 21, 2016 4:33 pm
Contact:

Re: Bugs & FAQ

Post by mageman1842 »

hey I got a problem with sulfur waste water. I'm using the "clean" coal recipe and trying to loop purified water back to the start but the pure water coming from the hydro plant (water to saline and pure) wont mix with the pure water from the hydro plant (sulfur, mineral water, pure). I've drained both sides thinking that it some how something else was in the line but after that hey pipes wont connect.

CrestLink
Manual Inserter
Manual Inserter
Posts: 1
Joined: Sun Jan 23, 2022 12:51 pm
Contact:

Re: Bugs & FAQ

Post by CrestLink »

Hi! I seem to have run in to an issue with nuclear researcher. I just researched Kovex Enrichment Prosses, but in the Centrifuges did not get the recipe for enriching U-235. Could this be a bug or am I missing something?

MonoS94
Manual Inserter
Manual Inserter
Posts: 1
Joined: Mon Jan 24, 2022 5:51 pm
Contact:

Re: Bugs & FAQ

Post by MonoS94 »

I think there is an issue in Trichlorosilane processing

Trichlorosilane (HCl3Si) processing require Hydrogen Cloride Gas (HCl) and processed silicon (Hydrogen Cloride Gas is made in equal parts from Hydrogen and Chlorine) and produce 120 units of Trichlorosilane and 30 units of Hydrogen, this means that an extra third of Hydrogen Gas is created as only 2/3 of it should be returned based on the chemical formula.

Code: Select all

30xHCl + 10Si => (10H+30Cl+10Si) + 20H => 10(HCl3Si) + 20H
Is this behavior intended?

Maraxus
Manual Inserter
Manual Inserter
Posts: 3
Joined: Mon Feb 06, 2017 4:08 pm
Contact:

Re: Bugs & FAQ

Post by Maraxus »

FNEI displays "Something went wrong" when looking at the following recipes in my current angel/bob game

1 Crystal Catalyst + 2 Saphirite Chucks + 2 Jivolite Chunks
1 Hybrid Catalyst + 2 Jivolite Crystals + 2 Crotinnium Crystals + 2 Rubyte Crystals
1 Hybrid Catalyst + 2 Purified Stiratite + 2 Purified Rubyte + 2 Purified Bobmonium
1 Hybrid Catalyst + 2 Purified Jivolite + 2 Purified Crotinnium + 2 Purified Rubyte

Mods enabled:

Actual_Craft_Time
angelsaddons-storage
angelsbioprocessing
angelsexploration
angelsindustries
angelspetrochem
angelsrefining
angelssmelting
bobassembly
bobelectronics
bobenemies
bobequipment
bobinserters
boblibrary
boblogistics
bobmining
bobmodules
bobores
bobplates
bobpower
bobrevamp
bobtech
bobvehicleequipment
bobwarfare
even-distribution
factoryplanner
flib
FNEI
ModuleInserter
Nanobots
pump
reskins-angels
reskins-bobs
reskins-compatibility
reskins-library
stdlib

eric
Manual Inserter
Manual Inserter
Posts: 4
Joined: Mon Sep 30, 2019 8:21 am
Contact:

Re: Bugs & FAQ

Post by eric »

I found an odd interaction between Bob's & Angel's playing the monthly reddit community map. A factory manufacturing the item circuit-board accepts the first three tiers of agricultural mods angels-bio-yield-module{,-2,-3}. This seems unlikely to be intended. It's unclear to me which mod is causing the problem.
The circuit board shows as Bob's Electronics Mod > Angel's Industries
The T2 agricultural mod (the one I'm using) shows as Angel's Bioprocessing > Bob's Technology Mod > Bob's Metals, Chemicals and Intermediates > Bob's Electronics > Bob's Greenhouse > Bob's Logistics > Bob's Revamp > Bob's Warfare > Bob's Modules > Angel's Bioprocessing

jamezzz6
Manual Inserter
Manual Inserter
Posts: 2
Joined: Sun Jan 30, 2022 10:09 pm
Contact:

Re: Bugs & FAQ

Post by jamezzz6 »

I don't know if this is a feature or a bug, but it looks like a bug and I can't find the solution anywhere so I'm asking here.

I would like to use the angels+bobs mods packs, but when using the Angel's Smelting mod no ores spawn near my starting position.
I attached a screenshot. The map exchange string is also provided.

I hope I am in the right place with this question...
weird maps.JPG
weird maps.JPG (223.3 KiB) Viewed 1279 times
>>>eNpjZGBkMGUAgwZ7EOYWTsxLT80p1k3KLEkt0i3OyUxJLYJJg
jAfVD4ts7i4tCgVWUoIKpWXWFJalJijm55YjCzNDZXOL0o1xCFuh
EPcGIe4CbI4S3J+Yg6yAGdyUWlKqm5+JoooV2peam6lblJiMYrjW
UuKUlNR3MvA+Oe7o3lDixwDCP+vZ1D4/x+EgawHwPACYQbGBohKo
BgMsCbnZKalMTAoOAKxE0iakYGxWmSd+8OqKUAmGOg5QBkfoCIHk
mAinjCGnwNOKRUYwwTJHGMw+IzEgFhaArIfoorDAcGASLaAJRl73
25d8P3YBTvGPys/XvJNSrBnNHQVeffBaJ0dUJId5E8mODFrJgjsh
HmFAWbmA3uo1E17xrNnQOCNPSMrSIcIiHCwABIHvJkZGAX4gKwFP
UBCQYYB5jQ7mDEiDoxpYPAN5pPHMMZle3R/AAPCBmS4HIg4ASLAF
sJdxghhOvQ7MDrIw2QlEUqA+o0YkN2QgvDhSZi1h5HsR3MIZkQg+
wNNRMUBSzRwgSxMgRMvmOGuAYbnBXYYz2G+AyMziAFS9QUoBuGBZ
GBGQWgBB3BwMzMgADBtXPv+aSIAUnLA9A==<<<

User avatar
Arch666Angel
Smart Inserter
Smart Inserter
Posts: 1636
Joined: Sun Oct 18, 2015 11:52 am
Contact:

Re: Bugs & FAQ

Post by Arch666Angel »

jamezzz6 wrote:
Sun Jan 30, 2022 10:15 pm
I don't know if this is a feature or a bug, but it looks like a bug and I can't find the solution anywhere so I'm asking here.

I would like to use the angels+bobs mods packs, but when using the Angel's Smelting mod no ores spawn near my starting position.
I attached a screenshot. The map exchange string is also provided.

I hope I am in the right place with this question...

weird maps.JPG

>>>eNpjZGBkMGUAgwZ7EOYWTsxLT80p1k3KLEkt0i3OyUxJLYJJg
jAfVD4ts7i4tCgVWUoIKpWXWFJalJijm55YjCzNDZXOL0o1xCFuh
EPcGIe4CbI4S3J+Yg6yAGdyUWlKqm5+JoooV2peam6lblJiMYrjW
UuKUlNR3MvA+Oe7o3lDixwDCP+vZ1D4/x+EgawHwPACYQbGBohKo
BgMsCbnZKalMTAoOAKxE0iakYGxWmSd+8OqKUAmGOg5QBkfoCIHk
mAinjCGnwNOKRUYwwTJHGMw+IzEgFhaArIfoorDAcGASLaAJRl73
25d8P3YBTvGPys/XvJNSrBnNHQVeffBaJ0dUJId5E8mODFrJgjsh
HmFAWbmA3uo1E17xrNnQOCNPSMrSIcIiHCwABIHvJkZGAX4gKwFP
UBCQYYB5jQ7mDEiDoxpYPAN5pPHMMZle3R/AAPCBmS4HIg4ASLAF
sJdxghhOvQ7MDrIw2QlEUqA+o0YkN2QgvDhSZi1h5HsR3MIZkQg+
wNNRMUBSzRwgSxMgRMvmOGuAYbnBXYYz2G+AyMziAFS9QUoBuGBZ
GBGQWgBB3BwMzMgADBtXPv+aSIAUnLA9A==<<<
You don't seem to have the full mod packs installed, or at least not full bobs, is this on purpose?

User avatar
KiwiHawk
Fast Inserter
Fast Inserter
Posts: 114
Joined: Thu Jul 05, 2018 9:48 am
Contact:

Re: Bugs & FAQ

Post by KiwiHawk »

jamezzz6 wrote:
Sun Jan 30, 2022 10:15 pm
I don't know if this is a feature or a bug, but it looks like a bug and I can't find the solution anywhere so I'm asking here.

I would like to use the angels+bobs mods packs, but when using the Angel's Smelting mod no ores spawn near my starting position.
I attached a screenshot. The map exchange string is also provided.

I hope I am in the right place with this question...
Try resetting your mod settings? There are settings to enable/disable each ore in the starting area. If you had previously been playing with Sea Block, those settings would all be disabled.
Dev for Bob's mods, Helmod, Sea Block, Circuit Processing. Contributor to Angel's mods

Buy me a coffee

User avatar
lovely_santa
Filter Inserter
Filter Inserter
Posts: 495
Joined: Sat Feb 18, 2017 9:41 pm
Contact:

Re: Bugs & FAQ

Post by lovely_santa »

Sworn wrote:
Sun Jan 16, 2022 1:52 am
Anyone got this weird error from angelsexploration?

Code: Select all

The mod Bob's Metals, Chemicals and Intermediates mod (1.1.3) caused a non-recoverable error.
Please report this error to the mod author.

Error while running event bobplates::on_configuration_changed
The mod Angel's Exploration (BETA) (0.3.13) caused a non-recoverable error.
Please report this error to the mod author.

Error while running event angelsexploration::on_technology_effects_reset (ID 102)
__angelsexploration__/src/tips-and-tricks-triggers.lua:50: attempt to index field '?' (a nil value)
stack traceback:
	__angelsexploration__/src/tips-and-tricks-triggers.lua:50: in function 'init_force_data'
	__angelsexploration__/src/tips-and-tricks-triggers.lua:120: in function 'on_tech_research_reset'
	__angelsexploration__/control.lua:89: in function <__angelsexploration__/control.lua:87>
stack traceback:
	[C]: in function 'reset_technology_effects'
	__bobplates__/control.lua:3: in function <__bobplates__/control.lua:1>

seems to have something to do when updating the ERM mods to the lasted version, but not really erm as root cause, cause when removing it from the mod list, it will run into the same error

current erm version if needed:
enemyracemanager_1.11.0
erm_toss_1.13.0
erm_marspeople_0.1.2
erm_redarmy_1.2.0
erm_zerg_1.13.1

also those were updated as well
Shortcuts-ick_1.1.22
vtk-deep-core-mining_2.9.1

save: https://drive.google.com/file/d/1GTz96l ... sp=sharing
Thanks for the report! I've created an [issue](https://github.com/Arch666Angel/mods/issues/764) so that it will be fixed for the next release.
mageman1842 wrote:
Sat Jan 22, 2022 8:15 pm
hey I got a problem with sulfur waste water. I'm using the "clean" coal recipe and trying to loop purified water back to the start but the pure water coming from the hydro plant (water to saline and pure) wont mix with the pure water from the hydro plant (sulfur, mineral water, pure). I've drained both sides thinking that it some how something else was in the line but after that hey pipes wont connect.
Sounds weird to me, can you post a save file to reproduce?
eric wrote:
Sun Jan 30, 2022 9:00 am
I found an odd interaction between Bob's & Angel's playing the monthly reddit community map. A factory manufacturing the item circuit-board accepts the first three tiers of agricultural mods angels-bio-yield-module{,-2,-3}. This seems unlikely to be intended. It's unclear to me which mod is causing the problem.
The circuit board shows as Bob's Electronics Mod > Angel's Industries
The T2 agricultural mod (the one I'm using) shows as Angel's Bioprocessing > Bob's Technology Mod > Bob's Metals, Chemicals and Intermediates > Bob's Electronics > Bob's Greenhouse > Bob's Logistics > Bob's Revamp > Bob's Warfare > Bob's Modules > Angel's Bioprocessing
I don't expect this to be a quite old save, but can you provide me a save file, I'll see if we forgot something...
You can find all my mods on the mod portal. Also helping on Arch666Angel's mods.
Image

Post Reply

Return to “Angels Mods”