[Lou] [1.1.35] blueprint wire ghost inconsistent behaviour

This subforum contains all the issues which we already resolved.
Post Reply
vakus
Manual Inserter
Manual Inserter
Posts: 2
Joined: Tue Jun 22, 2021 9:07 pm
Contact:

[Lou] [1.1.35] blueprint wire ghost inconsistent behaviour

Post by vakus »

Backstory

During my playing I noticed that wires from the blueprints would randomly not be build when filling in. I was curious to why only *some* chests had wires and some didn't so I experimented around and found a way to duplicate the bug.

What seems to be wrong

If logistic or non-logistic chest ghost is replaced with their opposite version, the condition wire is removed. e.g.
Ghost Wooden Chest (non-logistic) -> Passive Provider Chest (logistic)
Ghost Requester Chest (logistic) -> Steel Chest (non-logistic)

This however does not appear to happen for chests of the same type e.g.
Ghost Wooden Chest (non-logistic) -> Steel Chest (non-logistic)
Ghost Requester Chest (logistic) -> Passive Provider Chest (logistic)

The bug also does not happen if connected inserter is built before chest.

See included video for examples.

Whilst in provided example the inserters have no enable/disable condition, the bug happens regardless of it being set or unset

How should it work?

When a non-logistic chest replaces logistic chest, the wire should not be removed

About Game

Mods: Bug happens with mods and without any mods loaded
Version: 1.1.35 (build 58456, win64)
Release: Steam

Extras

I also made quick blueprint of the testing settup, which is available here: https://factoriobin.com/post/V5SEJ_Ug/0

The video is available here: https://www.youtube.com/watch?v=U8QWnQGZPIs

Original post I posted on r/factorio here: https://www.reddit.com/r/factorio/comme ... behaviour/

dvantreese
Manual Inserter
Manual Inserter
Posts: 3
Joined: Sat Feb 13, 2021 12:54 am
Contact:

Re: [Lou] [1.1.35] blueprint wire ghost inconsistent behaviour

Post by dvantreese »

Behavior is observed. When a chest is placed first, the wire is removed. However, if the inserter is placed first, the wire remains.

User avatar
Lou
Factorio Staff
Factorio Staff
Posts: 45
Joined: Mon Nov 30, 2020 10:50 am
Contact:

Re: [Lou] [1.1.35] blueprint wire ghost inconsistent behaviour

Post by Lou »

Thank you for the feedback. The issue is fixed for version 1.1.38.

Post Reply

Return to “Resolved Problems and Bugs”