Pump does not work in some positions

Don't know how to use a machine? Looking for efficient setups? Stuck in a mission?
Post Reply
Redstone_Tesla
Burner Inserter
Burner Inserter
Posts: 13
Joined: Sun Apr 22, 2018 6:22 pm

Pump does not work in some positions

Post by Redstone_Tesla » Sat Dec 01, 2018 12:50 pm

I can not make this pump work. I already tested it without the circuit and it still does not work.

https://imgur.com/5qvgglc
Can someone help me?

Zavian
Smart Inserter
Smart Inserter
Posts: 1119
Joined: Thu Mar 02, 2017 2:57 am

Re: Pump does not work in some positions

Post by Zavian » Sat Dec 01, 2018 1:21 pm

Not really enough info to be sure, but I think I recall an issue of pumps not connecting properly if the station isn't straight. (And I think the train must be in automatic mode as well).

nosports
Fast Inserter
Fast Inserter
Posts: 114
Joined: Fri Jan 19, 2018 5:44 pm

Re: Pump does not work in some positions

Post by nosports » Sat Dec 01, 2018 2:21 pm

i think the train is not stopped properly.....

To be sure place a railstation signal on a straight vertial or horizontal rail......

User avatar
eradicator
Smart Inserter
Smart Inserter
Posts: 2604
Joined: Tue Jul 12, 2016 9:03 am

Re: Pump does not work in some positions

Post by eradicator » Sat Dec 01, 2018 2:41 pm

Zavian wrote:
Sat Dec 01, 2018 1:21 pm
Not really enough info to be sure, but I think I recall an issue of pumps not connecting properly if the station isn't straight.
This. Pumps can not connect to trains if the station has curved rails. It won't work regardless of what you try. Curved stations sadly aren't supported for anything. They don't work correct with inserters either, where positions are shifted.
Author of: Hand Crank Generator, Screenshot Hotkey 2.0
Mod support languages: 日本語, Deutsch, English

Post Reply

Return to “Gameplay Help”