Odd behaviour when combining steam engines and solar panels

Don't know how to use a machine? Looking for efficient setups? Stuck in a mission?
Post Reply
Factorian
Inserter
Inserter
Posts: 26
Joined: Fri Jul 25, 2014 7:12 am
Contact:

Odd behaviour when combining steam engines and solar panels

Post by Factorian »

So up until now I mostly relied on steam power for everything and decided I needed a greener approach.

My existing steam engines were capable of producing 7 MW of energy at this time and I made sure they were fully fueled and all connected to the power network. When I added solar power initially everything was fine and they worked together nicely. However as soon as i produce more energy through solar power than i do through steam engines all of the steam engines shut down and leave me in a deficit for energy!

For example I will be getting 7 MW from steam and 6.9MW from solar, as soon as i add another few solar panels (so solar is producing 7.1MW) my entire steam engine network shuts down. This is not due to lack of fuel or lack of demand, the shutting down of the steam engines infact causes me to have no where near enough energy left. I'm not sure if this is a bug or a feature that im not properly understanding, any help?

EDIT: I have had this 'issue' on both 9.8 and 10.6 (if it is indeed an issue)

Mangledpork
Fast Inserter
Fast Inserter
Posts: 129
Joined: Fri Jul 25, 2014 7:03 pm
Contact:

Re: Odd behaviour when combining steam engines and solar pan

Post by Mangledpork »

So as soon as you do it, all of the engines shut off and everything starts running slowly? What happens if you do it at night, does the entire factory die altogether?

User avatar
ssilk
Global Moderator
Global Moderator
Posts: 12253
Joined: Tue Apr 16, 2013 10:35 pm
Contact:

Re: Odd behaviour when combining steam engines and solar pan

Post by ssilk »

Cool suggestion: Eatable MOUSE-pointers.
Have you used the Advanced Search today?
Need help, question? FAQ - Wiki - Forum help
I still like small signatures...

Factorian
Inserter
Inserter
Posts: 26
Joined: Fri Jul 25, 2014 7:12 am
Contact:

Re: Odd behaviour when combining steam engines and solar pan

Post by Factorian »

Mangledpork wrote:So as soon as you do it, all of the engines shut off and everything starts running slowly? What happens if you do it at night, does the entire factory die altogether?
At night time the solar power slowly drops off until it is 'below' what the steam engines would produce, as soon as it is below that threshold the steam all kicks in at once, going from 0 to 7.1 nearly in an instant

And ssilk that's the page i've been looking at, its very odd behaviour. Unfortunately i recently overwrite the save, I will get up to solar on my current play through and see if I can get a screenshot or two to demonstrate my issue

User avatar
ssilk
Global Moderator
Global Moderator
Posts: 12253
Joined: Tue Apr 16, 2013 10:35 pm
Contact:

Re: Odd behaviour when combining steam engines and solar pan

Post by ssilk »

Look, if you have disconnected your networks.
Cool suggestion: Eatable MOUSE-pointers.
Have you used the Advanced Search today?
Need help, question? FAQ - Wiki - Forum help
I still like small signatures...

Maddie
Burner Inserter
Burner Inserter
Posts: 14
Joined: Fri Jul 18, 2014 4:39 pm
Contact:

Re: Odd behaviour when combining steam engines and solar pan

Post by Maddie »

I have found that if my solar panels can produce enough energy to supply my factory, the steam engines will shut off.
I wil for example produce 100 MW with solar panels and also consume 100 MW.
However if I add more production the steam engines will slowly turn on if needed.

As I see it the solar panels have priority over the steam engines so the steam engines shut off if
they are not needed, and vice versa be turned on if the solar panels do not supply enough power.


Maddie

Factorian
Inserter
Inserter
Posts: 26
Joined: Fri Jul 25, 2014 7:12 am
Contact:

Re: Odd behaviour when combining steam engines and solar pan

Post by Factorian »

Maddie wrote:I have found that if my solar panels can produce enough energy to supply my factory, the steam engines will shut off.
I wil for example produce 100 MW with solar panels and also consume 100 MW.
However if I add more production the steam engines will slowly turn on if needed.

As I see it the solar panels have priority over the steam engines so the steam engines shut off if
they are not needed, and vice versa be turned on if the solar panels do not supply enough power.


Maddie
Yeah from what I can tell solar takes priority over steam which takes priority over accumulators stored energy. And if I was seeing the solar provide all the energy required then I would understand and be happy, the issue I am getting is that solar provides as much as it can, but isn't supplying enough (production bar is full) but my steam won't turn back on until my solars are off, despite being needed. It's very odd.

And yes ssilk, everything is all connected to the networks still, no breaks, no leaks, no accidental '2 separate networks'

Mangledpork
Fast Inserter
Fast Inserter
Posts: 129
Joined: Fri Jul 25, 2014 7:03 pm
Contact:

Re: Odd behaviour when combining steam engines and solar pan

Post by Mangledpork »

I'm itching to see a screenshot of the power menu, I use solar and steam all the time. I've been meaning to make a video about interpreting the power graphs for ages.

Factorian
Inserter
Inserter
Posts: 26
Joined: Fri Jul 25, 2014 7:12 am
Contact:

Re: Odd behaviour when combining steam engines and solar pan

Post by Factorian »

Mangledpork wrote:I'm itching to see a screenshot of the power menu, I use solar and steam all the time. I've been meaning to make a video about interpreting the power graphs for ages.
Heh, I'm working on it, only just started a new game so is taking me a while to get back to that point. (Plus your train tutorials are awesome by the way, just finished watching it)

EDIT: Oh! I think i've just realised what was happening, remembering back none of the machines were actually slowing down during this odd period, however on the network screen (I was on 5second view) it wasn't actually showing the energy supplied while it transitioned from steam to solar (thinking back it was only happening when it went from day to night or vice versa) is there a bug that means accumulators arent shown on the 'production' of energy graph?

Mangledpork
Fast Inserter
Fast Inserter
Posts: 129
Joined: Fri Jul 25, 2014 7:03 pm
Contact:

Re: Odd behaviour when combining steam engines and solar pan

Post by Mangledpork »

Ah, you were in 5 second view? I suspect you may be misinterpreting the graph then.
I think that the colours of the lines are determined by what produces more, rather than what specifically they are. It may be that when you increase solar capacity beyond steam, the colours are switching. Because you're using the 5 second view you may be missing the switch and thinking that everything goes all backwards for some reason. Make sure to use the key to see which line is which. I usually use a 10 minute view to look at steam and solar interacting, because it then contains a full day-night cycle and you can see solar switching off and on.
Accumulators are shown on production or consumption depending on if they're losing or gaining charge, and when using steam, solar and accumulators you get interesting interactions where steam can suddenly shut off or solar suddenly drop because accumulators have been filled again. I expect these can be massively confusing combined with switching colours and 5 second view.

And thanks for the compliment! :D

Factorian
Inserter
Inserter
Posts: 26
Joined: Fri Jul 25, 2014 7:12 am
Contact:

Re: Odd behaviour when combining steam engines and solar pan

Post by Factorian »

The colours switch!? Right that is probably the source of my confusion then, thanks for the guidance!

Mangledpork
Fast Inserter
Fast Inserter
Posts: 129
Joined: Fri Jul 25, 2014 7:03 pm
Contact:

Re: Odd behaviour when combining steam engines and solar pan

Post by Mangledpork »

I took a screenshot of a typical view of the power menu when using all three types of generation, but I can't get it to upload because I'm allergic to image systems in forums.

Post Reply

Return to “Gameplay Help”