[1.1.69] Mixed fluids from water pump

Don't know how to use a machine? Looking for efficient setups? Stuck in a mission?
Post Reply
zer0t
Burner Inserter
Burner Inserter
Posts: 8
Joined: Mon Nov 23, 2020 10:17 pm
Contact:

[1.1.69] Mixed fluids from water pump

Post by zer0t »

What did you do?
  1. Decided to play Factorio again :) and loaded my 1.1.X save that was working fine before
  2. Played for a while
  3. Closed the game
  4. Resumed from last save
  5. Noticed my fluid factory was not behaving as expected
  6. Tracked down the source of the problem to mixed fluids in pipes
  7. Noticed mixed fluids are produced from "lake/ocean" + "offshore pump" + "pump" (see screenshot)
What happened?
  1. I have an "offshore pump" from lake/ocean + "pump" connected to a pipe
  2. The pipe contains "water" + "Light oil"
What did you expect to happen instead? It might be obvious to you, but do it anyway!
  1. I have an "offshore pump" from lake/ocean + "pump" connected to a pipe
  2. The pipe contains only "water" and no "light oil"
What did I already try to fix it?
  • Empty "pipe" with "trash button" -> "Light oil" disappears -> "Light oil" appears again immediately
Savegame: https://nx7119.your-storageshare.de/s/TwPMp4QQN29mNpw
Logfile: https://nx7119.your-storageshare.de/s/8qZ6JLwWaYy6ykT
Screenshot:
fluid.png
fluid.png (244.24 KiB) Viewed 166 times

FuryoftheStars
Smart Inserter
Smart Inserter
Posts: 1414
Joined: Tue Apr 25, 2017 2:01 pm
Contact:

Re: [1.1.69] Mixed fluids from water pump

Post by FuryoftheStars »

So, that fluid it's showing you is not the contents of that pipe, but rather of the system as a whole that pipe is connected to. The problem is somewhere else.

Taking a brief look at your save, I see water in the pipes that are supposed to be light oil input for your chem plants, so I'd say the cross connection is somewhere in there, but your setup is so freaking huge, that I'm not taking the time to debug that. :lol: :P

zer0t
Burner Inserter
Burner Inserter
Posts: 8
Joined: Mon Nov 23, 2020 10:17 pm
Contact:

Re: [1.1.69] Mixed fluids from water pump

Post by zer0t »

Dammit, thx for the hint. Didn't pay attention, that it shows content of the whole system.

Time to debug....pls close

Post Reply

Return to “Gameplay Help”