[Twinsen][1.1.3] Wrong max consumption shown in tooltip for modded boiler with minimum_temperature

This subforum contains all the issues which we already resolved.
Post Reply
GotLag
Filter Inserter
Filter Inserter
Posts: 532
Joined: Sat May 03, 2014 3:32 pm
Contact:

[Twinsen][1.1.3] Wrong max consumption shown in tooltip for modded boiler with minimum_temperature

Post by GotLag »

The attached (very unfinished) mod adds a boiler that takes 165°C steam as input and heats it to 465°C
Its energy source is a 3.6MW burner with 200% efficiency, so it consumes as much fuel as a normal boiler to raise the steam temperature by twice as much.

When testing in-game it produces 465°C steam at 60 units/second, as it is intended to, but the entity tooltip's maximum consumption is calculated incorrectly:
Image
It appears to not be taking the minimum_temperature into account when calculating the maximum
Attachments
Superheating_0.0.1.zip
(1.3 KiB) Downloaded 22 times

Twinsen
Factorio Staff
Factorio Staff
Posts: 1234
Joined: Tue Sep 23, 2014 7:10 am
Contact:

Re: [Twinsen][1.1.3] Wrong max consumption shown in tooltip for modded boiler with minimum_temperature

Post by Twinsen »

Just to be clear, when you say "the entity tooltip's maximum consumption is calculated incorrectly", you mean the "Consumption 60/s of 40/s" and "Output: 60/s of 40/s" are incorrect and "Consumes Burnable fuel Max. consumption: 1.8 MW" is correct.

If so, then the issue is fixed in Version: 1.1.6.
It now takes into account minimum_temperature when calculating maximum flow.
It still uses prototype value and doesn't account for actual fluid temperature that was inputted, but this is necessary to avoid other problems.

Thanks for the report.

GotLag
Filter Inserter
Filter Inserter
Posts: 532
Joined: Sat May 03, 2014 3:32 pm
Contact:

Re: [Twinsen][1.1.3] Wrong max consumption shown in tooltip for modded boiler with minimum_temperature

Post by GotLag »

Ah, yes, sorry for not wording that clearly. I was referring to the fluid consumption/output and not the burnable fuel.

Thank you for fixing it.

Post Reply

Return to “Resolved Problems and Bugs”