[0.17.59][Linux] Del key does not toggle mod deletion sometimes

This subforum contains all the issues which we already resolved.
Post Reply
EnigmaticAussie
Fast Inserter
Fast Inserter
Posts: 129
Joined: Mon Dec 18, 2017 7:53 am
Contact:

[0.17.59][Linux] Del key does not toggle mod deletion sometimes

Post by EnigmaticAussie »

Browse installed mods.
Use *del* key to mark/unmark for deletion.
Sometimes it works, sometimes not.

I tried clicking the mod - del key does not work
Using arrow keys to navigate to the same mod - del key works.

User avatar
TheBloke
Fast Inserter
Fast Inserter
Posts: 123
Joined: Mon Dec 03, 2018 2:48 am
Contact:

Re: [0.17.59][Linux] Del key does not toggle mod deletion sometimes

Post by TheBloke »

I see the same on the Load game UI - and not just the Delete key. It appears that all keyboard input is broken on the Load UI, after a save game is selected with the mouse.

Specifically:
  1. Open the Load UI and, without using the mouse, try up/down arrow keys to scroll, and Delete to delete a save: it works
  2. Now use the mouse to click on a save
  3. Now repeat 1: keyboard no longer works
  4. This persists until the Load UI is closed and re-opened.
Same behaviour on both macOS 10.14.5 and Windows 10.

Rseding91
Factorio Staff
Factorio Staff
Posts: 12282
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.17.59][Linux] Del key does not toggle mod deletion sometimes

Post by Rseding91 »

Thanks for the report. It should be fixed for the next version of 0.17.
If you want to get ahold of me I'm almost always on Discord.

Post Reply

Return to “Resolved Problems and Bugs”