Page 1 of 1

[abregado][0.17.45]Compilatron skipping a step making the preview weird

Posted: Thu Jun 06, 2019 11:00 am
by mmmPI
I tried to break the thing on purpose as i was encouraged too, i had a good laugh and took it as a challenge.

I tried to capture the dangerous wildlife i found on this planet.
20190606114341_1.jpg (535.36 KiB) Viewed 1330 times
Compilatron is supposed to show you the way to automate iron smelting just after you get close to him.

but this is the end result after the zoom where you lose control.
20190606114420_1.jpg (580.33 KiB) Viewed 1330 times
I tried to catch it several times, it seems that after destroying the chest, he stands where it is supposed to build the furnaces burner mines ect, but instead there is the auto repair of the chest happening, and then he continue his patch "skipping a step" like Compilatron is mad at you for trying to get in his path.

( save trapped in chest 2 )

I am even more convince he holds a grudge since I made him look like a dog in other saves:

For this one i tried to gather what was in the structures but in the "wrong" order.

Used ctrl Left click on the most left chest not directly near the others. Then same thing on the 'middle' chest where you are supposed to use this hotkey.

Then i was waiting for Compilatron to explain to me the method you are supposed to use first and notice it was going back and forth between chest 1 and 2, waiting a few seconds nears chest 1 to tell me to pick it up.

(save trapped in a loop 1)

I thought it would be funny to stand exactly where he stops near chest 1 to tell me to pick up things.

Compilatron was having none of that fun and reliably let you know in the 5 seconds after you load this save if you don't move it will move you :)

(save trapped in a loop 2)

Re: [abregado][0.17.45]Compilatron skipping a step making the preview weird

Posted: Tue Jun 11, 2019 12:27 pm
by abregado
Fixed in latest version. Thanks for looking so close.