[0.17.24] Missing Unicode characters

This subforum contains all the issues which we already resolved.
Post Reply
tak3r
Manual Inserter
Manual Inserter
Posts: 2
Joined: Wed Apr 03, 2019 12:32 pm
Contact:

[0.17.24] Missing Unicode characters

Post by tak3r » Wed Apr 03, 2019 12:40 pm

Unicode characters in station names don't appear anymore.

Before I was able to use some unicode characters in train station names, like "⬅" and they would show up normally up till 0.17.24 (see screenshots for before/after)
They now all show up as empty space

running on Windows 10

Before
factorio-bug-unicode.png
factorio-bug-unicode.png (75.11 KiB) Viewed 290 times
After
factorio-bug-after.png
factorio-bug-after.png (59.86 KiB) Viewed 290 times

Bilka
Factorio Staff
Factorio Staff
Posts: 2323
Joined: Sat Aug 13, 2016 9:20 am
Contact:

Re: [0.17.25]

Post by Bilka » Wed Apr 03, 2019 1:02 pm

What language are you using?
I'm an admin over at https://wiki.factorio.com. Feel free to contact me if there's anything wrong (or right) with it.

tak3r
Manual Inserter
Manual Inserter
Posts: 2
Joined: Wed Apr 03, 2019 12:32 pm
Contact:

Re: [0.17.24] Missing Unicode characters

Post by tak3r » Wed Apr 03, 2019 1:59 pm

vanilla US English

eandmsz
Burner Inserter
Burner Inserter
Posts: 6
Joined: Mon Apr 01, 2019 9:43 am
Contact:

Re: [0.17.24] Missing Unicode characters

Post by eandmsz » Wed Apr 03, 2019 4:11 pm

I noticed the same with the Blueprint names. Unicode characters (🗲❖⚠❆⟁⚒☢) are shown as space (so they are not visible), but they are still there if I copy+paste them to notepad.
Windows 10 - English.

This happened after 0.17.23 to 0.17.24 update

project6
Inserter
Inserter
Posts: 22
Joined: Sat Aug 15, 2015 10:31 pm
Contact:

Re: [0.17.24] Missing Unicode characters

Post by project6 » Sun Apr 07, 2019 10:07 pm

Same behaviour noted for me as well using unicode geometric shapes (https://www.compart.com/en/unicode/block/U+25A0):
Many unicode characters are replaced by spaces.
I replicated this behaviour in the en, fr, ko, and zn-TW locales.

For the ru locale I got "blank boxes" instead.
blank box.PNG
blank box.PNG (43.61 KiB) Viewed 173 times

kovarex
Factorio Staff
Factorio Staff
Posts: 7424
Joined: Wed Feb 06, 2013 12:00 am
Contact:

Re: [0.17.24] Missing Unicode characters

Post by kovarex » Mon Apr 08, 2019 3:08 pm

Thanks for the report, this is fixed for the next release by reverting to the previous font.

Post Reply

Return to “Resolved Problems and Bugs”

Who is online

Users browsing this forum: No registered users