[0.17.4] [MacOS] Delays in control

This subforum contains all the issues which we already resolved.
AHappyPandaBear
Manual Inserter
Manual Inserter
Posts: 3
Joined: Fri May 05, 2017 11:02 am
Contact:

Re: [0.17][Mac] Delays in control

Post by AHappyPandaBear »

It seems like when using scroll (zoom in/out) it somehow locks the controlls (wasd) and thereby the controls get delayed - seems to be connected to vsync because disabling it eliminates delays.

Using Trackpad on 2018 MacBook Pro 15' on MacOS v10.14.3 with Radeon Pro 555X 4096 MB
Had no issues in 0.16.X and had vsync enabled - PM me if you need any more info

danielbrauer
Long Handed Inserter
Long Handed Inserter
Posts: 93
Joined: Thu May 18, 2017 2:22 pm
Contact:

Re: [0.17][Mac] Delays in control

Post by danielbrauer »

I have this issue on my MacBook as well. What it feels like is that the game is running at a solid 60fps, but then something will happen (zooming in or out, running a long distance, opening the Research window) that reduces the frame rate. Instead of dropping render frames, Factorio just slows everything down until rendering catches up. So everything lags, even though it all feels relatively smooth, you see commands issued a second or two later, and tooltips trailing the mouse cursor. Then after a few seconds it catches up, and the game is responsive again.

My guess is that Factorio should be dropping frames, but it's not. Is it possible that you stop everything while waiting for the vertical blank, even when the frame rate is low? This would explain why it works fine without V-sync, since it doesn't have to wait for anything.
Last edited by danielbrauer on Fri Mar 01, 2019 10:31 am, edited 1 time in total.

_italics_
Burner Inserter
Burner Inserter
Posts: 16
Joined: Sat Jan 05, 2019 3:28 pm
Contact:

Re: [0.17][Mac] Delays in control

Post by _italics_ »

With V-Sync off it's playable, but with a lot of tearing. Whenever the frame rate drops (e.g. when zooming in on a bunch of active labs), it stops responding to input until it has caught up.

No such issues on my Windows machine.

slama
Manual Inserter
Manual Inserter
Posts: 2
Joined: Thu Feb 28, 2019 8:14 pm
Contact:

Re: [0.17][Mac] Delays in control

Post by slama »

Hey, I registered just to report I'm having this bug.

MacBook Pro (15-inch, Late 2016), MacOS 10.14 (18A391) with Intel HD Graphics 530 1536 MB.

manjhi
Inserter
Inserter
Posts: 34
Joined: Mon Nov 12, 2018 10:23 pm
Contact:

Re: [0.17][Mac] Delays in control

Post by manjhi »

Same issue on 2018 MacBook Pro with Radeon Pro 555X 4096 MB.

Vsync on -> delay during scrolling - zooming in/out
Vsync off -> tearing graphical glitch on a horizontal line that's about 1 tile wide. the line keeps moving vertically across the screen very slowly.

AlmightyJu
Burner Inserter
Burner Inserter
Posts: 16
Joined: Wed Dec 13, 2017 9:54 pm
Contact:

Re: [0.17][Mac] Delays in control

Post by AlmightyJu »

billbo99 wrote:
Wed Feb 27, 2019 10:29 am
I am ALSO getting this on my PC, I have a 4k monitor with G-Sync .. when I play on my 1080p monitor response is fine.
Strangely I'm getting this on my 4k G-Sync monitor too with windows

User avatar
brunzenstein
Smart Inserter
Smart Inserter
Posts: 1012
Joined: Tue Mar 01, 2016 2:27 pm
Contact:

Re: [0.17][Mac] Delays in control

Post by brunzenstein »

manjhi wrote:
Thu Feb 28, 2019 8:30 pm
Same issue on 2018 MacBook Pro with Radeon Pro 555X 4096 MB.

Vsync on -> delay during scrolling - zooming in/out
Vsync off -> tearing graphical glitch on a horizontal line that's about 1 tile wide. the line keeps moving vertically across the screen very slowly.
Same for me on a top notch MacBook Pro - never happened under 0.16x

onelastword
Manual Inserter
Manual Inserter
Posts: 3
Joined: Fri Mar 01, 2019 4:36 am
Contact:

Re: [0.17][Mac] Delays in control

Post by onelastword »

Here to report I'm also having delays in control. The framerate and UPS still says 60/60. This is on a brand new game so it is not large factory delays and this is on local single player.

makrom
Inserter
Inserter
Posts: 33
Joined: Fri Apr 28, 2017 2:27 pm
Contact:

Re: [0.17][Mac] Delays in control

Post by makrom »

I can confirm it as being related to VSYNC, usually caused when zooming in and out, then persisting for a few second. Without VSYNC it's gone but constant screen tearing around character height.

User avatar
brunzenstein
Smart Inserter
Smart Inserter
Posts: 1012
Joined: Tue Mar 01, 2016 2:27 pm
Contact:

Re: [0.17][Mac] Delays in control

Post by brunzenstein »

makrom wrote:
Fri Mar 01, 2019 6:20 am
I can confirm it as being related to VSYNC, usually caused when zooming in and out, then persisting for a few second. Without VSYNC it's gone but constant screen tearing around character height.
The "screen tearing around character height" remains no matter how small or big a factory is. Actually that "screen tearing around character height" is persistent right from the start of the game.

Lumus
Manual Inserter
Manual Inserter
Posts: 4
Joined: Mon Oct 23, 2017 9:59 pm
Contact:

Re: [0.17][Mac] Delays in control

Post by Lumus »

Hi all,

I am experiencing this on my late 2013 MacBook Pro with nVidia GT750 card. Turning off vsync helps, but I notice the issue during load as well when the sprites are being loaded into VRAM and I’m trying to use the system in the background (e.g. safari). I use a tool called iStat Menus and I can see the GPU is being pegged at 100% during this process and VRAM is almost totally filled.

Also, perhaps coincidentally, the system believes that GOG Galaxy is using nearly all the available CPU power.

Hope this helps
Attachments
Screen Shot 2019-03-01 at 07.46.16.png
Screen Shot 2019-03-01 at 07.46.16.png (291.63 KiB) Viewed 1586 times

manjhi
Inserter
Inserter
Posts: 34
Joined: Mon Nov 12, 2018 10:23 pm
Contact:

Re: [0.17][Mac] Delays in control

Post by manjhi »

Looks like it might take a while to have this issue fixed considering there's no Mac developer on their team. Sucks.

We have to choose between lag and annoying graphics glitch.

Hope they figure this out soon.

publife
Manual Inserter
Manual Inserter
Posts: 1
Joined: Fri Mar 01, 2019 6:15 pm
Contact:

Re: [0.17][Mac] Delays in control

Post by publife »

Registered an account just to post in this thread - having all the issues as described and also on high spec Macbook Pro. Really hoping this can get sorted - I'm super keen to play 0.17 but it's basically a non-starter for mac users right now.

Assembling_machine_2
Manual Inserter
Manual Inserter
Posts: 3
Joined: Fri Mar 01, 2019 11:08 pm
Contact:

Re: [0.17.4] [Mac] Delays in control

Post by Assembling_machine_2 »

seems to happen when zooming and moving at same time, very annoying

User avatar
ssilk
Global Moderator
Global Moderator
Posts: 12253
Joined: Tue Apr 16, 2013 10:35 pm
Contact:

Re: [0.17][Mac] Delays in control

Post by ssilk »

Lumus wrote:
Fri Mar 01, 2019 7:49 am
Also, perhaps coincidentally, the system believes that GOG Galaxy is using nearly all the available CPU power.
Interesting. In my case (viewtopic.php?f=47&t=66243) the system says firefox was using 40% CPU. But there was only the edit window of the forum open.

I also recognised quite a lot of lag in the mods-setup so it is not limited to the game, but also happens in the menu.
I can confirm, that with turning vsync of it gets better, especially in the mods-setup it works then useable fast, but not in game.
Cool suggestion: Eatable MOUSE-pointers.
Have you used the Advanced Search today?
Need help, question? FAQ - Wiki - Forum help
I still like small signatures...

User avatar
ssilk
Global Moderator
Global Moderator
Posts: 12253
Joined: Tue Apr 16, 2013 10:35 pm
Contact:

Re: [0.17][Mac] Delays in control

Post by ssilk »

automationfor wrote:
Tue Feb 26, 2019 11:38 pm
My hypothesis is that, like many games, the 'retina display' affects performance negatively - and if we could manually set the resolution of the game independent of the OS it could improve this issue.
Could be, cause the font is much too small for this screen size, with 100% gui-size I can barely read it, compared to 0.16 I need to increase it to 150%.
Cool suggestion: Eatable MOUSE-pointers.
Have you used the Advanced Search today?
Need help, question? FAQ - Wiki - Forum help
I still like small signatures...

StapledBattery
Manual Inserter
Manual Inserter
Posts: 4
Joined: Fri Mar 01, 2019 11:02 pm
Contact:

Re: [0.17.4] [MacOS] Delays in control

Post by StapledBattery »

It feels like the game isn't processing mouse events fast enough. It will run fine until I move the mouse, then everything will start lagging behind.

Sidan
Manual Inserter
Manual Inserter
Posts: 4
Joined: Thu Feb 28, 2019 5:39 pm
Contact:

Re: [0.17.4] [MacOS] Delays in control

Post by Sidan »

Same problem, on MacBook Pro 2011 Intel HD Graphics 3000 512 MB. 0.16 ran like a charm. Turning off Vsync does make the game playable on a new game, but the delay still occurs regularly for several seconds, and my large bases from 0.16 are unplayable. Please fix soon <3

User avatar
brunzenstein
Smart Inserter
Smart Inserter
Posts: 1012
Joined: Tue Mar 01, 2016 2:27 pm
Contact:

Re: [0.17.4] [MacOS] Delays in control

Post by brunzenstein »

Sidan wrote:
Sat Mar 02, 2019 12:04 pm
Same problem, on MacBook Pro 2011 Intel HD Graphics 3000 512 MB. 0.16 ran like a charm. Turning off Vsync does make the game playable on a new game, but the delay still occurs regularly for several seconds, and my large bases from 0.16 are unplayable. Please fix soon <3
👍

Attal
Inserter
Inserter
Posts: 21
Joined: Fri Dec 23, 2016 9:49 am
Contact:

Re: [0.17.4] [MacOS] Delays in control

Post by Attal »

Hello!

My factorio 0.17 is totally unplayable...

few days ago(0.17.2) i've found the problem, (post here: viewtopic.php?f=182&t=65606#p402469)
Please have a look FPS on Mac (MBP mid15, i7, 16gb, but integrated video) - it was enough for 4rpm megabase 0.16

new small map, 0.17.2 vanilla
https://streamable.com/s/4eo7f/jkelfv
on 6-7th second i've hovered on the copper patch (~10 pieces), tooltip was shown on 15-30th second

+ when the game is running (map opened) menu buttons highlight works with a big lag, also scrolling in browser work with huge lags
+ when the game is running (the main menu opened) everything renders gently (menu buttons highlight and browser)
+ on video avg fps is 14, without recording is near 20
today, according to @posila advice I've reverted all graphics settings
and made new video https://streamable.com/f4h4l

Delays in control are huge - i've stopped pressing D (right) on 15th secong on video, than i've started press A (left) but character stopped only in the forest, and then run back.
Details tooltip shown with very big delay after hover
Attachments
factorio-current.log
(7.85 KiB) Downloaded 24 times

Post Reply

Return to “Resolved Problems and Bugs”