[0.16.18] Desyncs while running

This subforum contains all the issues which we already resolved.
LazyDev
Inserter
Inserter
Posts: 36
Joined: Thu Jan 25, 2018 1:47 am
Contact:

Re: [0.16.18] Desyncs while running

Post by LazyDev »

I'm getting constant desyncs with 0.16.18. No one can join my game infact. I was just about to post this bug, but then I saw this thread.

Running Linux Mint 18.3,

Rseding91
Factorio Staff
Factorio Staff
Posts: 11930
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.16.18] Desyncs while running

Post by Rseding91 »

LazyDev wrote:I'm getting constant desyncs with 0.16.18. No one can join my game infact. I was just about to post this bug, but then I saw this thread.

Running Linux Mint 18.3,
Are you able to test hosting the game on your computer and connecting to it as well to see if it still desyncs? Assuming you're running linux as your client.
If you want to get ahold of me I'm almost always on Discord.

LazyDev
Inserter
Inserter
Posts: 36
Joined: Thu Jan 25, 2018 1:47 am
Contact:

Re: [0.16.18] Desyncs while running

Post by LazyDev »

Rseding91 wrote:
LazyDev wrote:I'm getting constant desyncs with 0.16.18. No one can join my game infact. I was just about to post this bug, but then I saw this thread.

Running Linux Mint 18.3,
Are you able to test hosting the game on your computer and connecting to it as well to see if it still desyncs? Assuming you're running linux as your client.
I don't know how to do that

Edit (Linux client -> Linux server):

I've managed to launch a server, then joined it. No desync issues. This is Linux to Linux, tho.

Image

Edit #2 (Windows client -> Linux Server):

I got Windows 10 running my virtual machine, then connected to the headless server (Running on Linux) and sure enough, I got a desync.

Image:
Image

Desync:
https://drive.google.com/open?id=1wHlTC ... WKSVBRnuKL

Rseding91
Factorio Staff
Factorio Staff
Posts: 11930
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [0.16.18] Desyncs while running

Post by Rseding91 »

Is anyone able to test mac client -> linux server and mac client -> windows server?

Literally all I have access to is windows so I can't test anything...
If you want to get ahold of me I'm almost always on Discord.

LazyDev
Inserter
Inserter
Posts: 36
Joined: Thu Jan 25, 2018 1:47 am
Contact:

Re: [0.16.18] Desyncs while running

Post by LazyDev »

I don't own any apple products, unfortunately.

silvervest
Burner Inserter
Burner Inserter
Posts: 8
Joined: Fri May 26, 2017 4:40 am
Contact:

Re: [0.16.18] Desyncs while running

Post by silvervest »

Rseding91 wrote:Is anyone able to test mac client -> linux server and mac client -> windows server?
I'll do both of these right now, stay tuned
EDIT-
I took my known bad map from my main server and copied it to a fresh linux server without mods
Mac client => linux server, desyncs almost immediately (~3-5 seconds) upon joining

Took the same map file, and copied it to a windows server and ran headless
Mac client => windows server, desyncs almost immediately (~2 seconds) upon joining

For reference, the Mac, Windows and Linux systems are all on the same local network, however the Mac is over wifi where as the Linux and Windows are hard wired.
This map is approx 15MB and the desync reports about 120MB ea. Let me know if you'd like either (AU internet will take a bit of time to upload them)

silvervest
Burner Inserter
Burner Inserter
Posts: 8
Joined: Fri May 26, 2017 4:40 am
Contact:

Re: [0.16.18] Desyncs while running

Post by silvervest »

Just for fun, I tried Windows server => windows client and while I couldn't get a desync to occur, I did notice some *really* weird biter/spitter behaviour.

I engaged a group, they chased after me then after a short distance, they seemed to lose interest, start wandering around in circles then just one by one they vanished. I've just run the original save and I can reproduce this over and over. Will upload a video shortly.
EDIT- video: https://www.youtube.com/watch?v=rpudeEylNXs

greaman
Inserter
Inserter
Posts: 34
Joined: Sat Sep 24, 2016 6:41 am
Contact:

Re: [0.16.18] Desyncs while running

Post by greaman »

Rseding91 wrote:Is anyone able to test mac client -> linux server and mac client -> windows server?

Literally all I have access to is windows so I can't test anything...
Tested as well and I same consistent problem with

Mac Client -> Linux server
Win Client -> Linux server
edit: same issue with a windows Server

The only difference is the perceived frequency of desyncs which feels higher on the Mac.

elderdakkar
Manual Inserter
Manual Inserter
Posts: 2
Joined: Wed Jan 24, 2018 6:52 pm
Contact:

Re: [0.16.18] Desyncs while running

Post by elderdakkar »

LInux client => linux server also desyncs

HOSH
Long Handed Inserter
Long Handed Inserter
Posts: 51
Joined: Mon Nov 28, 2016 12:04 am
Contact:

Re: [0.16.18] Desyncs while running

Post by HOSH »

Been running a heavily mod list bobs+ and same issues running windows client to Linux headless. Seeing it occur when biters beginning to move in packs, or when grouping up for an attack... Also when trying to run, but I guess a group of biters could be moving/grouping up and not see it on radar, so... Can post, but will have mods in it.

From what I can tell in the logs it looks like it is adjusting the latency between the host and server as the biters move that is causing it. But that is just me trying to read the log file in the desync and noticing what is happening. I fought through the desyncs and cleaned up 90% of the attacks as I setup a perimeter wall outside pollution cloud and I have not desynced since.

rhinoliar
Manual Inserter
Manual Inserter
Posts: 2
Joined: Wed Jan 24, 2018 2:41 am
Contact:

Re: [0.16.18] Desyncs while running

Post by rhinoliar »

Cannot play because of desync, 3 persons are getting disconnected and following connection automatically desycs everyone again in 1-2 seconds. We have to rollback to previos saves where person have not approached bitters yet, loosing our progress and game satisfaction.

ps. guys come on are you serious? not having a linux/mac/windows whatever environments for testing sounds like a very bad excuse, dozens are getting affected not to mention the ones who are not reporting this issue.

User avatar
steinio
Smart Inserter
Smart Inserter
Posts: 2595
Joined: Sat Mar 12, 2016 4:19 pm
Contact:

Re: [0.16.18] Desyncs while running

Post by steinio »

What's up with you? Change back to 0.15 stable if you don't have the nerves for a test branch.
Image
Transport Belt Repair Man

View unread Posts

bmario
Manual Inserter
Manual Inserter
Posts: 2
Joined: Tue Jan 23, 2018 10:58 pm
Contact:

Re: [0.16.18] Desyncs while running

Post by bmario »

I just updated to 0.16.19. Unfortunately, the issue persists.

MrMaleficus
Manual Inserter
Manual Inserter
Posts: 1
Joined: Sun Aug 21, 2016 2:41 pm
Contact:

Re: [0.16.18] Desyncs while running

Post by MrMaleficus »

Hello,

I just found a solution, hope it will help.
You just have to make your game peaceful until the bug is fixed :

Code: Select all

/c game.player.surface.peaceful_mode=true
and disable the peaceful mode when it's fixed

Code: Select all

/c game.player.surface.peaceful_mode=false

LazyDev
Inserter
Inserter
Posts: 36
Joined: Thu Jan 25, 2018 1:47 am
Contact:

Re: [0.16.18] Desyncs while running

Post by LazyDev »

Would that command disable achievements?

TitanicFreak
Manual Inserter
Manual Inserter
Posts: 4
Joined: Tue Jan 23, 2018 2:41 pm
Contact:

Re: [0.16.18] Desyncs while running

Post by TitanicFreak »

LazyDev wrote:Would that command disable achievements?
Yes, however for people like me who got all of the achievements possible already. It's honestly not a problem.

silvervest
Burner Inserter
Burner Inserter
Posts: 8
Joined: Fri May 26, 2017 4:40 am
Contact:

Re: [0.16.18] Desyncs while running

Post by silvervest »

I just tried this, didn't immediately work. Got in again and issued

Code: Select all

/c game.forces.enemy.kill_all_units()
at which point the desyncs stopped

To test some stuff out I wandered around for a while, placed some buildings etc then went and attacked a nest - then the desync hit. Definitely seems to be something to do with being attacked.

ewpolly1
Manual Inserter
Manual Inserter
Posts: 3
Joined: Sun Nov 06, 2016 8:48 am
Contact:

Re: [0.16.18] Desyncs while running

Post by ewpolly1 »

I am also having issues with Mac <> Windows desyncs. I have a desync report from a windows client with a mac host, if you would like I can test this the other way around to generate a desync report from a mac playing on a windows device. The game desyncs after the first minute or so after connecting.

The desync report can be found at https://drive.google.com/file/d/1QlcB3r ... sp=sharing.

Hope I'm able to help!

ewpolly1
Manual Inserter
Manual Inserter
Posts: 3
Joined: Sun Nov 06, 2016 8:48 am
Contact:

Re: [0.16.18] Desyncs while running

Post by ewpolly1 »

I've tested the game on a Windows Host <> Mac Client now. The game took longer to crash, although that may just be random luck. The map is the same as the previous save, and the desync report can be found at https://drive.google.com/file/d/1M7jWW8 ... sp=sharing.

You were saying something about the desync being related to biter pathing, and while in the previous desync report I uploaded, we were not doing anything with biters (They were likely attacking part of our base where we weren't, however), in this desync, it happened after the player on the windows host drove a tank to an alien nest.

Hope this helps!

TitanicFreak
Manual Inserter
Manual Inserter
Posts: 4
Joined: Tue Jan 23, 2018 2:41 pm
Contact:

Re: [0.16.18] Desyncs while running

Post by TitanicFreak »

silvervest wrote:I just tried this, didn't immediately work. Got in again and issued

Code: Select all

/c game.forces.enemy.kill_all_units()
at which point the desyncs stopped

To test some stuff out I wandered around for a while, placed some buildings etc then went and attacked a nest - then the desync hit. Definitely seems to be something to do with being attacked.
Yup, can see the same on my private server. Biters are the source for us for desyncs.

Post Reply

Return to “Resolved Problems and Bugs”