Page 1 of 1

[posila] [0.16.1] Circuit wire shadows are offset from connector

Posted: Thu Dec 14, 2017 11:25 am
by Atria
Shadows of wires of circuit connections don't align with shadows of circuit connectors (bottom chests in second image). Shadows of two seperate wires connected to one entity don't even connect at single point (power pole in second image).

Imgur album of examples

Re: [16.1] Circuit wire shadows are offset from connector

Posted: Thu Dec 14, 2017 11:31 am
by Loewchen
Post your log please, in case this can not be reproduced.

Re: [16.1] Circuit wire shadows are offset from connector

Posted: Thu Dec 14, 2017 11:40 am
by Atria
Upst, sorry. There it is.

Re: [16.1] Circuit wire shadows are offset from connector

Posted: Thu Dec 14, 2017 11:50 am
by Loewchen
I am not able to reproduce this with: Graphics quality: normal

Re: [16.1] Circuit wire shadows are offset from connector

Posted: Thu Dec 14, 2017 2:08 pm
by Atria
Loewchen wrote:I am not able to reproduce this with: Graphics quality: normal
I tested normal vs high sprite resolution.
On normal the problem is less noticible, but it's still there (power pole ok, chest wires still bit disconnected).
On high resolution the problem is still the same.

Difference shown in attachements.

Re: [posila] [0.16.1] Circuit wire shadows are offset from connector

Posted: Wed May 30, 2018 11:48 am
by lovely_santa
Bilka suggested to add this info while i was modding a constant combinator entity (locked in north orientation)...
lovely_santa wrote: @Bilka is this a bug? When the wire distance gets longer, the shadow of the wires moves up a bit?
unknown[1].png
unknown[1].png (1.38 MiB) Viewed 737 times
(the upper one i used as reference, the shadow is correct, and then with the 2 underneath its moving up)
well its concistent over all distances
unknown[1].png
unknown[1].png (724.69 KiB) Viewed 737 times
except the 1 space and the one near:
unknown[1].png
unknown[1].png (1.27 MiB) Viewed 737 times
bot are each shifted up by 0.1 and and 0.2 respectivly
same on vanilla constant combinators FYI

Also, i've noticed that the wire actualy don't reach to the connection point but starts 1 pixel next to it (in HQ graphics). Resulting in 2 pixels space between 2 wires
kind regards,
lovely_santa

Re: [posila] [0.16.1] Circuit wire shadows are offset from connector

Posted: Tue Dec 04, 2018 9:50 am
by Optera
Shadows of constant combinators are vertically misaligned too.
2018-12-04-10-48-24-8251636.png
2018-12-04-10-48-24-8251636.png (88.58 KiB) Viewed 490 times

Re: [posila] [0.16.1] Circuit wire shadows are offset from connector

Posted: Tue Jun 11, 2019 5:03 pm
by posila
Thanks for the report.
As far as I can tell, this is not an issue in 0.17.48 anymore.

Re: [posila] [0.16.1] Circuit wire shadows are offset from connector

Posted: Wed Jun 12, 2019 5:46 am
by Optera
posila wrote:
Tue Jun 11, 2019 5:03 pm
Thanks for the report.
As far as I can tell, this is not an issue in 0.17.48 anymore.
Wire shadows are aligned nicely for combinators now.
Chests, especially logistics variants, could use a bit more tweaking:
2019-06-12-07-46-35-4861149.png
2019-06-12-07-46-35-4861149.png (64.51 KiB) Viewed 88 times