[14.21] Crash when mining car on: "EquipmentGrid::clear" (reproducible)

This subforum contains all the issues which we already resolved.
Post Reply
XBBX
Long Handed Inserter
Long Handed Inserter
Posts: 72
Joined: Wed Jan 07, 2015 4:30 pm
Contact:

[14.21] Crash when mining car on: "EquipmentGrid::clear" (reproducible)

Post by XBBX »

crash report
Mods
Save

Just exit car and mine it
Edit: If i remove items from cars grid and then mine it then it is ok no crash

Rseding91
Factorio Staff
Factorio Staff
Posts: 11928
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [14.21] Crash when mining car on: "EquipmentGrid::clear" (reproducible)

Post by Rseding91 »

Interesting. With your save I was able to find quite a few bugs related to mod removal and the vehicle <> equipment grid logic :)

Anyway, this is fixed for 0.15. It's a bug with LuaItemStack::set_stack when setting from an existing ItemWithEntityData that contains a grid. It will always crash.
If you want to get ahold of me I'm almost always on Discord.

Rseding91
Factorio Staff
Factorio Staff
Posts: 11928
Joined: Wed Jun 11, 2014 5:23 am
Contact:

Re: [14.21] Crash when mining car on: "EquipmentGrid::clear" (reproducible)

Post by Rseding91 »

In the mean time, if you remove the inventory sort mod you won't get the crash.
If you want to get ahold of me I'm almost always on Discord.

XBBX
Long Handed Inserter
Long Handed Inserter
Posts: 72
Joined: Wed Jan 07, 2015 4:30 pm
Contact:

Re: [14.21] Crash when mining car on: "EquipmentGrid::clear" (reproducible)

Post by XBBX »

Hmm interesting. Its not a big problem for me i can just leave car on the ground now then i now where's the problem i can avoid it
Its not first time i get crashed like this but first time i was able to replicate
Good to now it will be fixed in .15

Post Reply

Return to “Resolved Problems and Bugs”