[Donion] [1.1.69] Lab sounds start synchronised

This subforum contains all the issues which we already resolved.
Post Reply
User avatar
Kayanor
Global Moderator
Global Moderator
Posts: 565
Joined: Sat May 10, 2014 7:20 am
Contact:

[Donion] [1.1.69] Lab sounds start synchronised

Post by Kayanor »

Lab working sounds will also synchronise if the game is set to not automatically pause on finished research but you still manage to pause the game in that exact moment.

Description:
When the game is set to not pause after research is finished, if you open the technology screen (no queue) in the exact moment the research finishes and start a new research, all lab working sounds will synchronise and become loud. This however goes away after another pause cycle or if the research finishes next time.
Here is a video in which I demonstrate these issues with the "show-environment-sound-info" debug option enabled. There is also a weird dip in the lab sound volume at one point, I can't reproduce that.

What I expected:
Lab sounds are randomised, even if you open the technology screen frame-perfect. :twisted:

What I got:
Lab working sounds synchronise if the technology screen is opened immediately after research finishes.

Steps to reproduce:
-> Lab working sounds synchronise
  1. Also works best in god controller with show-environment-sound-info enabled
  2. interface setting "Technology screen opens when research is completed" should be disabled
  3. research queue should be disabled (might work with it enabled, not tested)
  4. Find yourself some labs
  5. if not already researching, start researching something, then resume the game
  6. lab working sounds should play randomised ("progress boxes" show random progress)
  7. open technology screen as soon as research finishes (could require frame-perfect input)
  8. select a new research
  9. resume the game
  10. lab working sounds play synchronised ("progress boxes" all show same progress)
  11. pause the game and resume it
  12. lab working sounds are randomised again
  13. repeat steps 7 to 10, so the sounds are synchronised again
  14. wait until research finishes (no frame-perfect input this time)
  15. start a new research and resume the game
  16. lab working sounds are randomised again
Edit: split original post into two
Attachments
Testomatik.zip
That weird savegame I used in the video.
(2.92 MiB) Downloaded 21 times
factorio-current.log
(5.83 KiB) Downloaded 22 times
Former moderator.

Donion
Factorio Staff
Factorio Staff
Posts: 98
Joined: Sun Aug 22, 2021 9:18 am
Contact:

Re: [Donion] [1.1.69] Lab sounds start synchronised

Post by Donion »

Thanks for the exhaustive report. The issue is an incorrect interaction of working sound which is fading out and pausing the game (opening the technology screen).
With labs you have whole 20 ticks while the sound is fading out to pause the game and trigger this issue. :)
Note: this only happens with the SDL audio backend as Allegro handles fade out when pausing differently.
This is now fixed for next release.

Post Reply

Return to “Resolved Problems and Bugs”