[15.33] Server not responding, yet able to download

This subforum contains all the issues which we already resolved.
Post Reply
BenSeidel
Filter Inserter
Filter Inserter
Posts: 513
Joined: Tue Jun 28, 2016 1:44 am

[15.33] Server not responding, yet able to download

Post by BenSeidel » Fri Aug 18, 2017 11:43 am

So, for whatever reason I cannot connect to a server, even though I am getting a full download speed.
server not responding.jpg
server not responding.jpg (221.71 KiB) Viewed 1448 times
Server keeps "timing out" while downloading.
disconnected.jpg
disconnected.jpg (216.51 KiB) Viewed 1448 times
attached log file of the current session.

The server I am trying to connect to has a ping of about 468ms. Usually I can connect, albeit after 2 or 3 attempts, most ending in a zero download speed then a disconnect. This is the first occasion where it disconnects while it's downloading!
I can usually download at about 350KB/s, but it apparently wants to sit between 190-205 tonight.
Attachments
factorio-current.log
(1.03 MiB) Downloaded 23 times

TsBandit
Burner Inserter
Burner Inserter
Posts: 12
Joined: Sat Aug 20, 2016 4:46 pm

Re: Server not responding, yet able to download

Post by TsBandit » Sat Aug 19, 2017 5:02 pm

Similar bug report: viewtopic.php?f=7&t=51784

BenSeidel
Filter Inserter
Filter Inserter
Posts: 513
Joined: Tue Jun 28, 2016 1:44 am

Re: Server not responding, yet able to download

Post by BenSeidel » Sun Aug 20, 2017 1:21 am

TsBandit wrote:Similar bug report: viewtopic.php?f=7&t=51784
That report is about the UI freezing. My UI remains functional through the entire process (the screen gets redrawn).
My bug report is "Your file download protocol uses 110% of the internet connection making the heartbeat useless"
and I know it's using too much of my bandwidth because it literally terminates every other connection that is running over the internet at that time and I am unable to ping my ISP's server, something that should only occur when my Internet goes down.

SyncViews
Fast Inserter
Fast Inserter
Posts: 161
Joined: Thu Apr 21, 2016 3:17 pm

Re: Server not responding, yet able to download

Post by SyncViews » Mon Aug 28, 2017 10:30 am

I see this "Server not responding" pop up for a few moments when downloading for pretty much any server (generally between 1MB/s and 3MB/s although Factorio is pretty inconsistent, even to the same machine). The download bar keeps progressing even with the "server not responding" bar, but normally it goes away again before half full.

User avatar
eradicator
Smart Inserter
Smart Inserter
Posts: 2604
Joined: Tue Jul 12, 2016 9:03 am

Re: [15.33] Server not responding, yet able to download

Post by eradicator » Tue Aug 29, 2017 2:36 pm

I get the "sever not responding" dialog popping up and vanishing a few seconds later too. This happens particularly often when the conncection has high ping to the server to begin with (different continent).

Also whenever i'm "downloading map" nobody in Teamspeak can understand me (they get gibberish), while i understand them just fine, suggesting that the upload is overtaxed.
Author of: Hand Crank Generator, Screenshot Hotkey 2.0
Mod support languages: 日本語, Deutsch, English

User avatar
Philip017
Fast Inserter
Fast Inserter
Posts: 231
Joined: Thu Sep 01, 2016 11:21 pm

Re: [15.33] Server not responding, yet able to download

Post by Philip017 » Fri Sep 01, 2017 6:23 pm

i have noticed this with many people that try and join my cloud server as well, they will download the map really fast, but get the 'being dropped' message at the same time, if they dont get the download finished before the being dropped bar is filled they will be disconnected from the server.

I have a router with QOS measures, so i dont have the same issues, but for anyone that lacks these features in their router, they will have problems as the download saturates the available internet connection.

perhaps it could discontinue heartbeat checks if the download is moving, if the download stops moving in the time a heartbeat would normally take it could send a heartbeat and if there is no response begin the dropping of player timeout.

kovarex
Factorio Staff
Factorio Staff
Posts: 6674
Joined: Wed Feb 06, 2013 12:00 am

Re: [15.33] Server not responding, yet able to download

Post by kovarex » Thu Sep 07, 2017 3:07 pm

I checked the net code, and I realized, that there is a potential problem. We order the download to get slower when the server requests packets to be resent, but if it is so bad, that even the request for the packet doesn't arrive the client doesn't do anything until it is disconnected.
So I made a change for 0.16, that the download will get hint to slow down even when the client needs to re-request packets from the server.

Lets see if it helps.

BenSeidel
Filter Inserter
Filter Inserter
Posts: 513
Joined: Tue Jun 28, 2016 1:44 am

Re: [15.33] Server not responding, yet able to download

Post by BenSeidel » Fri Sep 08, 2017 6:27 am

Thanks. Sounds like it should fix the issue.

BenSeidel
Filter Inserter
Filter Inserter
Posts: 513
Joined: Tue Jun 28, 2016 1:44 am

Re: [15.33] Server not responding, yet able to download

Post by BenSeidel » Wed Nov 07, 2018 11:51 am

Hi,
The fix did not work, well it works, but not as intended. When I connect to some servers, the "Server is not responding" keeps moving across the screen and the download is reasonably quickly make slower and slower. So it just kills the download speed, down to 20kB/s some time... This is quite funny as I can download off steam and other services up to 4MB/s.

I think it has something to do with my ping (as I am in the most geographically isolated capital city in the world). And before anyone starts, YES!!! I regularly play games with 800-1200ms ping! That is just NORMAL for me.
Attachments
factorio-current.log
(415.36 KiB) Downloaded 5 times

Post Reply

Return to “Resolved Problems and Bugs”