[Twinsen] [0.15.16] Silo continues building part even after completion

This subforum contains all the issues which we already resolved.

[Twinsen] [0.15.16] Silo continues building part even after completion

Postby Jon8RFC » Wed May 31, 2017 9:29 am

The Rocket silo, regardless of productivity or speed modules, will start building a new rocket part after it's finished the one it's working on. I'm guessing this isn't intended since it doesn't fully continue to build a second part while it's waiting to launch.

It's not a graphical glitch, because I got it up to 99% completion, then manually inserted the full capacity of 64 intermediate parts each, so to complete the part it should have 54 remaining, but in the screenshot you can see that the progress bar has moved and the parts remaining are only 44.
Attachments
Screenshot_2017-05-31__04.14.05.PNG
Screenshot_2017-05-31__04.14.05.PNG (976.95 KiB) Viewed 779 times
Image
User avatar
Jon8RFC
Filter Inserter
Filter Inserter
 
Posts: 292
Joined: Tue May 10, 2016 3:39 pm
Location: Austin, TX

Re: [Twinsen] [0.15.16] Silo continues building part even after completion

Postby Twinsen » Mon Jun 19, 2017 2:02 pm

I not sure if there was much point in fixing this, but it was done.

Fixed in Version: 0.15.22.
Twinsen
Factorio Staff
Factorio Staff
 
Posts: 671
Joined: Tue Sep 23, 2014 7:10 am
Location: Factorio HQ

Re: [Twinsen] [0.15.16] Silo continues building part even after completion

Postby Jon8RFC » Sat Feb 24, 2018 11:46 am

This one is back. I haven't played my save in so long that I'm not sure when it actually came back.
Image
User avatar
Jon8RFC
Filter Inserter
Filter Inserter
 
Posts: 292
Joined: Tue May 10, 2016 3:39 pm
Location: Austin, TX

Re: [Twinsen] [0.15.16] Silo continues building part even after completion

Postby Rseding91 » Sun Feb 25, 2018 3:01 pm

Jon8RFC wrote:This one is back. I haven't played my save in so long that I'm not sure when it actually came back.


I can't reproduce. If you can please make a new bug report with the required steps.
If you want to get ahold of me I'm almost always on IRC and Discord.
Rseding91
Factorio Staff
Factorio Staff
 
Posts: 7470
Joined: Wed Jun 11, 2014 5:23 am

Re: [Twinsen] [0.15.16] Silo continues building part even after completion

Postby Jon8RFC » Sat Mar 03, 2018 6:03 pm

False alarm.

Finally figured it out--it's the rare occasion when the productivity module completes the build from 99% to 100%, and it has a few-pixel wide green bar and blank purple bar, which only looked like the original bug.
Image
User avatar
Jon8RFC
Filter Inserter
Filter Inserter
 
Posts: 292
Joined: Tue May 10, 2016 3:39 pm
Location: Austin, TX


Return to Resolved Problems and Bugs

Who is online

Users browsing this forum: No registered users and 7 guests