[15.32] Uranium Ore causes bad Framerate

This subforum contains all the issues which we already resolved.

[15.32] Uranium Ore causes bad Framerate

Postby Algo-ryth-mix » Thu Aug 03, 2017 8:53 pm

Whenever my Player gets near to a Patch of Uranium Ore the Framerate drops severely (noticeably under 60, between 20 and 15). I only experience this with Uranium Ore. My Pc should be able to handle such a load pretty easily. (Ryzen7 1800x@3.85GHz 16Gb Ram & Gtx1070HOF 8Gb VDDR5). I noticed that some people have reported bad frame rate in 0.15 but I didn't find one that was so specific.
Attached are some images with screenshots &the log & the save:
factorio-current.log
logfile
(40.49 KiB) Downloaded 25 times


Here you can see the bad framerate & all my settings
Screenshot (4).png
Screenshot (4).png (3.87 MiB) Viewed 1913 times


Framerate way better same scenario
Screenshot (5).png
Screenshot (5).png (3.69 MiB) Viewed 1913 times

Server mim Leo.zip
save
(13.09 MiB) Downloaded 10 times

(edit: my nvidia driver is 384.94 btw)
Algo-ryth-mix
Burner Inserter
Burner Inserter
 
Posts: 5
Joined: Fri Aug 14, 2015 3:34 pm
Location: Austria

Re: [15.32] Uranium Ore causes bad Framerate

Postby posila » Thu Aug 03, 2017 9:07 pm

Can you try if changing "Lights render resoltion" to minimum (0.25 I think) improves the FPS?
posila
Factorio Staff
Factorio Staff
 
Posts: 1884
Joined: Thu Jun 11, 2015 1:35 pm

Re: [15.32] Uranium Ore causes bad Framerate

Postby Algo-ryth-mix » Thu Aug 03, 2017 9:33 pm

changing this to 0.25 does nothing
Screenshot (6).png
Screenshot (6).png (3.71 MiB) Viewed 1903 times
Algo-ryth-mix
Burner Inserter
Burner Inserter
 
Posts: 5
Joined: Fri Aug 14, 2015 3:34 pm
Location: Austria

Re: [15.32] Uranium Ore causes bad Framerate

Postby Algo-ryth-mix » Thu Aug 03, 2017 10:22 pm

Note that this also happens when using the Map + Radar View
Algo-ryth-mix
Burner Inserter
Burner Inserter
 
Posts: 5
Joined: Fri Aug 14, 2015 3:34 pm
Location: Austria

Re: [15.32] Uranium Ore causes bad Framerate

Postby posila » Mon Aug 07, 2017 10:40 am

Thanks for the screenshots with debug info. I think I fixed it for 0.15.33.
posila
Factorio Staff
Factorio Staff
 
Posts: 1884
Joined: Thu Jun 11, 2015 1:35 pm

Re: [15.32] Uranium Ore causes bad Framerate

Postby orzelek » Wed Aug 09, 2017 9:10 pm

Out of curiosity - what was the culprit here?
orzelek
Smart Inserter
Smart Inserter
 
Posts: 2806
Joined: Fri Apr 03, 2015 10:20 am

Re: [15.32] Uranium Ore causes bad Framerate

Postby posila » Thu Aug 10, 2017 9:12 am

On the screenshots I noticed big increase in draw calls (from 239 without uranium ore, to 2067 with uranium). We render draw glow layer over the ore. I move rendering of the glow to higher layer, so it doesn't break batching if uranium ore sprite and the glow sprite don't fall into the same sprite atlas.
Note: I saw the increase in draw call count on my computer too, but didn't experience any FPS drops. I have GTX 750Ti.
posila
Factorio Staff
Factorio Staff
 
Posts: 1884
Joined: Thu Jun 11, 2015 1:35 pm

Re: [15.32] Uranium Ore causes bad Framerate

Postby Algo-ryth-mix » Sat Aug 12, 2017 8:18 pm

I can confirm that Version 0.15.33 fixes this issue, gliding over uranium ore is now buttery smooth
Algo-ryth-mix
Burner Inserter
Burner Inserter
 
Posts: 5
Joined: Fri Aug 14, 2015 3:34 pm
Location: Austria


Return to Resolved Problems and Bugs

Who is online

Users browsing this forum: No registered users and 3 guests