Search found 218 matches

by luc
Tue Apr 30, 2019 8:54 pm
Forum: Not a bug
Topic: [0.17.32] Reading belt with circuit network changes item's position
Replies: 9
Views: 1321

Re: [0.17.32] Reading belt with circuit network changes item's position

So the workaround is to make sure the items are adjacent? E.g. fill it up with dummy items that do not play a sound if you want spacing?
by luc
Tue Apr 30, 2019 8:53 pm
Forum: Tools
Topic: Search the Factorio Knowledge Base, also known as FFF
Replies: 2
Views: 1840

Re: Search the Factorio Knowledge Base, also known as FFF

Thank you for the kind words!
by luc
Sat Apr 27, 2019 10:32 am
Forum: Releases
Topic: Version 0.17.34
Replies: 12
Views: 10460

Re: Version 0.17.34

[*] Improved fluid simulation threading. Decreases CPU usage. Threading available on all operating systems. Simulation performance should remain unchanged. I don't understand this one. Fluid simulation is better threaded and decreases CPU usage... but performance should remain unchanged? Will it ge...
by luc
Wed Apr 24, 2019 9:10 pm
Forum: Not a bug
Topic: [0.17.32] Reading belt with circuit network changes item's position
Replies: 9
Views: 1321

Re: [0.17.32] Reading belt with circuit network changes item's position

So... I don't completely understand what you said, but sounds like the code could be made to not perform the force-unmerge when the belt is set to read-only mode?

Can we cure it, doctor?
by luc
Wed Apr 24, 2019 8:14 pm
Forum: Not a bug
Topic: [0.17.32] Reading belt with circuit network changes item's position
Replies: 9
Views: 1321

Re: [0.17.32] Reading belt with circuit network changes item's position

Savefile: https://lgms.nl/tmp/factorio-sound.zip I just tested it in single player, and it also occurs there. To quickly reproduce, running the game at speed 50 (not sure how much of that I actually reached, probably only like 10× speed or so) for a minute or two shows the effect. At full zoom, it i...
by luc
Mon Apr 22, 2019 11:30 pm
Forum: Not a bug
Topic: [0.17.32] Reading belt with circuit network changes item's position
Replies: 9
Views: 1321

[0.17.32] Reading belt with circuit network changes item's position

Context: I made a simple music editor that reads a belt and plays different notes on the programmable speaker for different items. https://i.snag.gy/xa3Fw4.jpg The items were (painstakingly) spaced apart to make a simple tune, but as can be seen in the screenshot, the items have grouped into blocks....
by luc
Mon Apr 22, 2019 12:36 pm
Forum: Mods
Topic: [MOD 0.17.x] Ammo-Loader
Replies: 15
Views: 11579

Re: [MOD 0.16] Ammo-Loader

I can't use this mod in 0.17 anymore: it causes my game to try to use >10GB of memory when loading the map (and RAM is still more expensive today than it was in 2016, so I didn't upgrade to 16GB yet). Without this mod, it uses about 5.5GB.
by luc
Mon Apr 22, 2019 12:00 pm
Forum: Won't fix.
Topic: Walls Render Over Belts,Splitters and Underground Belts
Replies: 4
Views: 1055

Re: Walls Render Over Belts,Splitters and Underground Belts

Err okay, I don't know how I never noticed that. Just checked in my local game, you're right of course. I hope I can unsee this, maybe it will now bother me until the end of time :P
by luc
Mon Apr 22, 2019 11:32 am
Forum: Pending
Topic: [0.17.31] Train's periodically stops a few tiles to late at a station
Replies: 6
Views: 1028

Re: [0.17.31] Train's periodically stops a few tiles to late at a station

just a generel save of the game, or where the fault has occured ? The save file of the map on which you get this issue. Like, if you go to Play -> Load game -> myepicbase, then the file myepicbase.zip is what you should attach so that the devs can load it up in their development environments and se...
by luc
Mon Apr 22, 2019 11:28 am
Forum: Duplicates
Topic: [0.17.32] Incompatability when connecting to stress test on 21/07/2019 with vanila install from steam.
Replies: 2
Views: 300

Re: [0.17.32] Incompatability when connecting to stress test on 21/07/2019 with vanila install from steam.

Looks similar to my bug a few days ago: https://forums.factorio.com/viewtopic.php?f=47&t=69585 The answer was "you messed up the game files, just do a fresh install". I don't remember messing with my files, though. Did you do anything odd to your files? At the very least, I'd say the e...
by luc
Sat Apr 20, 2019 11:47 pm
Forum: Won't fix.
Topic: Walls Render Over Belts,Splitters and Underground Belts
Replies: 4
Views: 1055

Re: Walls Render Over Belts,Splitters and Underground Belts

That one seems to have been fixed though -- at least, I assume that I would totally have noticed a train with inserters looking buggy like that. Pretty crappy to close a bug report as "meh, won't fix this, too much work" and then later do it anyway without posting back to the original thre...
by luc
Sat Apr 20, 2019 7:53 pm
Forum: Resolved Problems and Bugs
Topic: [Oxyd] [0.17.32] Crash when connecting to server (InputActionDefragmenter::assemble)
Replies: 4
Views: 1649

[Oxyd] [0.17.32] Crash when connecting to server (InputActionDefragmenter::assemble)

Just got a crash trying to connect to the stress test while it was trying to catch up. I don't think it caught up, it was going quite slow, though I alt-tabbed away so I can't be sure. I turned off crash uploading because I hadn't had a crash in years and I'd report it manually anyway. I understand ...
by luc
Tue Apr 16, 2019 6:31 pm
Forum: Duplicates
Topic: [0.17.31] Could not load downloaded map, trying to apply migration
Replies: 3
Views: 1017

Re: [0.17.31] Could not load downloaded map, trying to apply migration

No mods are (or have been) installed in my 0.17 install, both client and server.

As for the version, I wrote "the server is also at 0.17.31".

As for why multiplayer would even by trying to apply migrations? Maybe that's the bug ;)
by luc
Mon Apr 15, 2019 10:22 pm
Forum: Duplicates
Topic: [0.17.31] Could not load downloaded map, trying to apply migration
Replies: 3
Views: 1017

[0.17.31] Could not load downloaded map, trying to apply migration

Not sure if this is a bug, or if I did something wrong somehow (I don't remember having messed in the data/ folder (where the migration files are) or anything, just did autoupdates... I think after downloading an initial 0.17.x fresh). When trying to join a multiplayer game (the server is also at 0....
by luc
Fri Apr 12, 2019 6:44 pm
Forum: Releases
Topic: Version 0.17.30
Replies: 4
Views: 6443

Re: Version 0.17.30

Loading the login page for me is also really slow for a few days now. Might be related / not sure if anyone brought that up yet? (I kind of assume someone must have by now, but just to make sure)
by luc
Wed Apr 10, 2019 5:13 pm
Forum: Releases
Topic: Version 0.17.28
Replies: 25
Views: 13037

Re: Version 0.17.28

gorbag wrote:
Wed Apr 10, 2019 1:50 pm
I always knew we couldn't trust trees.

a: Oh so you're a vegetarian! You must love the little animals!
b: No, I just HATE vegetables!
Amen! :lol:
by luc
Tue Apr 09, 2019 10:23 pm
Forum: News
Topic: Friday Facts #288 - New remnants, More bugs
Replies: 60
Views: 18091

Re: Friday Facts #288 - New remnants, More bugs

One of the fun parts of fixing the difficult bugs is putting the reproduction steps in the changelog and watching peoples reactions when they read the patch notes for that release.
This is one of the reasons I read them. Often enjoyable, and I sometimes share them with friends :)
by luc
Tue Apr 09, 2019 10:12 pm
Forum: Releases
Topic: Version 0.17.28
Replies: 25
Views: 13037

Re: Version 0.17.28

Stable updates for desktop went from 73.0.3683.86 to 73.0.3683.103. But hey, I guess they don't know how to version either :) Of course they do! Google can't do anything wrong, ever. It's like when mail from your mail server is marked as spam by Gmail, it must be your fault, google can't be wrong a...
by luc
Tue Mar 26, 2019 10:37 pm
Forum: Releases
Topic: Version 0.17.21
Replies: 15
Views: 11888

Re: Version 0.17.21

Would be interesting to see the crash spikes that caused the rapid release, might be nice to include it again in the FFF :)

Go to advanced search