Search found 46 matches

by ixnorp
Mon Jul 04, 2016 9:18 pm
Forum: Duplicates
Topic: [0.13.0] Terrain segmentation
Replies: 50
Views: 10382

Re: [0.13.0] Terrain segmentation

Another thing i've noticed is if I set enemy spawns to low or very low everything, but starting area to "none" it's as if the biter settings got turned to very high. That sounds reasonable because if you don't have a starting area there's no ramp of difficulty. It's more of a mod option, like the o...
by ixnorp
Mon Jul 04, 2016 9:12 pm
Forum: Resolved Problems and Bugs
Topic: [0.13.x] [cube] game.regenerate_entity is just... wrong.
Replies: 6
Views: 1427

Re: [0.13.x] game.regenerate_entity is just... wrong.

I wonder if this is some how connected to the behavior I observed at viewtopic.php?p=174148#p174148 with "water in starting area only" where the starting area code seems to cover the entire map instead of being confined to, well, the starting area.
by ixnorp
Mon Jul 04, 2016 9:08 pm
Forum: Ideas and Suggestions
Topic: Save games record more version & mod data
Replies: 0
Views: 198

Save games record more version & mod data

I've been reading the bug report forums a lot lately and I see a few questions pop up very frequently even when the save file is attached to the OP: What version did you start this map on? Did you migrate this map from version X to version Y? Have you used any mods? Perhaps save files ought to recor...
by ixnorp
Mon Jul 04, 2016 3:35 pm
Forum: Resolved Problems and Bugs
Topic: [0.13.4] [UX issue] [Hanziq] Unnecessary restarts
Replies: 1
Views: 382

Re: [0.13.4] [UX issue] Unnecessary restarts

I installed all of Bob's Mods via the mod portal when 0.13 first came out just to see how it all worked. I was pretty tired of restarting after the 15th time or so.
by ixnorp
Sat Jul 02, 2016 12:11 pm
Forum: Duplicates
Topic: [0.13.0] Terrain segmentation
Replies: 50
Views: 10382

Re: [0.13.0] Terrain segmentation

However, they did not acknowledged the terrain generation is bugged "There have been many complains regarding the terrain generation, we didn't encounter these problems in our games, but we should probably go back to it and tweak it a little." To me, that's like "no idea what you're talking about, ...
by ixnorp
Sat Jul 02, 2016 5:22 am
Forum: Resolved Problems and Bugs
Topic: *[13.1]Train PF don't give penalty to circuit closed signal
Replies: 16
Views: 5818

Re: [13.0] Train not going to available station, waiting on red

How costly is it in terms of processing to have a train re-evaluate its path or to add something like path finding weights for paths which will clearly never be available or the time to wait is unknown? Could trains re-evaluate their paths, say, once a second (every few seconds?) when stopped (even ...
by ixnorp
Sat Jul 02, 2016 4:58 am
Forum: Resolved Problems and Bugs
Topic: [Network Protocol] Connection brokering potential DDOS
Replies: 12
Views: 3389

Re: [Network Protocol] Connection brokering potential DDOS

So it seems like their idea of UDP NAT punching in order to avoid using TCP has basically resulted in needing to re-implement much of TCP... except in UDP? Oh NAT, will there be no end to your screwing up of the internet. https://www.factorio.com/blog/post/fff-143 https://www.factorio.com/blog/post/...
by ixnorp
Sat Jul 02, 2016 3:46 am
Forum: Duplicates
Topic: [0.13.0] Terrain segmentation
Replies: 50
Views: 10382

Re: [0.13.0] Terrain segmentation

I just finished my 0.12.35 map which migrated to 0.13 and decided to start a new game. Now on 0.13.2 This segmentation totally ruins all maps! After near 30 attempts I just could not get a single map I could agree to play on. Totally rediculous! Please fix asap! Yeah. I wanted to start fresh for 0....
by ixnorp
Fri Jul 01, 2016 6:14 am
Forum: Duplicates
Topic: Crash on update 0.13.0 -> 0.13.1
Replies: 2
Views: 273

Re: Crash on update 0.13.0 -> 0.13.1

I had an error while updating from 0.13.1 to 0.13.2 and it looks like the same issue as this one (Error Util.cpp:77) so I'm posting it here instead of making a new thread. Just like the OP, no obvious issues or problems after the update but I felt I may as well report it anyways since a crash is a c...
by ixnorp
Fri Jul 01, 2016 5:26 am
Forum: Not a bug
Topic: map generation speed depends on game speed
Replies: 2
Views: 409

Re: map generation speed depends on game speed

This may not be a bug but it would be really handy to have listed on the wiki somewhere. I came across the force.chart() function when wanting to reveal large areas of maps for comparison but I never ran into the fact it's tied to game speed until now. This would have been really helpful as I was wo...
by ixnorp
Fri Jul 01, 2016 4:59 am
Forum: Resolved Problems and Bugs
Topic: [0.13.1] Map generation process is very strange
Replies: 31
Views: 15856

Re: [0.13.1] Map generation process is very strange

I'd love to see a blending of the new biome generation with the old. This new pattern gives more interest locally, but becomes monotonous on a large scale. The old one gave nice variation globally, but was rather repetitive locally. Segmentation, Biomes, and Starting Resources seem like the only is...
by ixnorp
Thu Jun 30, 2016 7:26 pm
Forum: Duplicates
Topic: [0.13.0] Terrain segmentation
Replies: 50
Views: 10382

Re: [0.13.0] Terrain segmentation

I did some investigation of this and compared different 0.13 map generation settings. https://forums.factorio.com/viewtopic.php?f=7&t=27521 Based on https://forums.factorio.com/viewtopic.php?f=173&t=20858 it seems like something that's going to be ignored for a while while they're fighting more imme...
by ixnorp
Thu Jun 30, 2016 7:23 am
Forum: Not a bug
Topic: 13.1 Game doesn't check supported versions of mods on update
Replies: 13
Views: 1419

Re: [0.13.1] Close to desktop after upgrade breaks installed mod

Mods have to be tested by the mod developer, not the game developer. NaB Yes. If we disabled a mod the first time it had an error during loading making a mod would be a giant pain the ass. Contact the mod author about fixing their mods. Perhaps a config file directive along the lines of AutoDisable...
by ixnorp
Thu Jun 30, 2016 7:07 am
Forum: Resolved Problems and Bugs
Topic: [0.13] Factorio no longer works on Windows XP
Replies: 20
Views: 4930

Re: [0.13] Factorio no longer works on Windows XP

First point: Does you team actively not support Windows XP anymore? That can be a problem, as you might have somebody go to the court to get back the price of a new windows version and, depending on you country, might even get it. Same problem might occur to the Factorio devs. Really? Microsoft off...
by ixnorp
Wed Jun 29, 2016 3:15 pm
Forum: Bob's mods
Topic: [0.13.x] Bob's Mods: General Discussion
Replies: 439
Views: 68287

Re: [0.13.x] Bob's Mods: General Discussion

So, i dont know if its something to do with some new way of handling biter expansion or if its a bug somewhere in bobs, but i started a new game, played for an hour. I noticed a base near me, i checked it out, it had 2 large worms, one of them poison, that felt a little buggy? https://forums.factor...
by ixnorp
Wed Jun 29, 2016 2:08 pm
Forum: Resolved Problems and Bugs
Topic: [0.13.0] [Hanziq] "API call failed" during mod browsing [reopened]
Replies: 20
Views: 4193

Re: [0.13.0] "API call failed" during mod browsing [reopened]

After clicking through enough mods on the portal I eventually get a CTD from API call failed 0.000 2016-06-29 07:00:19; Factorio 0.13.1 (Build 22864, win64, alpha) 0.000 Operating system: Windows 10 0.000 Program arguments: "E:\Factorio_0.13_Fresh_Install\bin\x64\Factorio.exe" "--wait-to-close" "110...
by ixnorp
Wed Jun 29, 2016 1:43 pm
Forum: Bob's mods
Topic: [0.13.x] Bob's Mods: General Discussion
Replies: 439
Views: 68287

Re: [0.13.x] Bob's Mods: General Discussion

Error message is

Code: Select all

Error while loading entity prototype "diesel-locomotive-2" (locomotive): No such node (reversing_power_modifier)
Modifications: boblogistics
So you guessed correctly.
by ixnorp
Wed Jun 29, 2016 12:13 pm
Forum: Resolved Problems and Bugs
Topic: [0.13.1] Map generation process is very strange
Replies: 31
Views: 15856

[0.13.1] Map generation process is very strange

edit: Changing the title to 0.13.1 after a brief test to confirm that 0.13.1 is generating identical maps. Summary Water Only In Starting Area causes many small lakes to be generated all over the map. Increasing the amount of water on a map decreases the size of biomes. The underlying first step of ...
by ixnorp
Wed Jun 29, 2016 3:51 am
Forum: General discussion
Topic: Taking a screen shot of the Map (not the game world)
Replies: 4
Views: 719

Re: Taking a screen shot of the Map (not the game world)

If your specific problem is oil, it might be easier to install a mod that makes oil patches more visible. Do you have any suggestions for this in particular? I took a look over http://www.factoriomods.com/most-popular/category/oil and a brief Google search but didn't see anything outstanding for th...
by ixnorp
Wed Jun 29, 2016 12:38 am
Forum: General discussion
Topic: Taking a screen shot of the Map (not the game world)
Replies: 4
Views: 719

Re: Taking a screen shot of the Map (not the game world)

Have you tried using the map editor? You can use the same map gen settings and try different seeds and then scroll around to view the map in detail. There is no fog of war in the editor so you can look at as much of the map as you want. This was what I was doing at first, but I got tired of waiting...

Go to advanced search