Search found 532 matches

by GotLag
Sat Oct 26, 2019 9:35 am
Forum: Ideas and Suggestions
Topic: [0.17] Link Production and Consumption scaling graphs
Replies: 3
Views: 542

Option/button to display production/consumption graphs at same scale

As per the thread title, it would be nice to have an interface setting or UI button to have power and item production and consumption graphs display on the same Y scale.

Particularly for items, this would make it easier to see at a glance how production and consumption for a particular item compare.
by GotLag
Sat Oct 26, 2019 9:23 am
Forum: Outdated/Not implemented
Topic: Personal robots prioritizing nearest first
Replies: 186
Views: 28356

Construction bots from personal roboports should build closest first

The bot tile placement improvements in the latest FFF are interesting, but for placing entities I think it would help a lot of bots originating from a personal roboport prioritised construction based on distance. It would make placing rail tracks from a train much quicker, and would allow players to...
by GotLag
Tue Apr 09, 2019 12:35 am
Forum: Resolved Problems and Bugs
Topic: [0.17.14] Recipes with more than one instance of the same ingredient
Replies: 34
Views: 6690

Re: [0.17.14] Recipes with more than one instance of the same ingredient

Also because it's frankly a relatively minor issue that only affects one or two mods.
by GotLag
Sat Apr 06, 2019 11:05 am
Forum: Resolved Problems and Bugs
Topic: [0.17.14] Recipes with more than one instance of the same ingredient
Replies: 34
Views: 6690

Re: [0.17.14] Recipes with more than one instance of the same ingredient

Rseding already said that duplicate products will be allowed again in the next version. I really dont want to stress or anything. But with this change my whole mod pack is not working anymore, i need to disable bio processing and other mods relay on it. Cant you push a quick update to correct this?...
by GotLag
Tue Mar 26, 2019 4:45 pm
Forum: Modding interface requests
Topic: Add a "blueprint as" property
Replies: 4
Views: 474

Re: Add a "blueprint as" property

Okay, that also works with copy-paste if you use events.on_player_setup_blueprint and make the appropriate checks, thanks.

Still, the entities/tiles need to have (hidden, non-craftable) items defined to place them for them to be selectable for blueprints/copying
by GotLag
Tue Mar 26, 2019 4:07 pm
Forum: Modding interface requests
Topic: Add a "blueprint as" property
Replies: 4
Views: 474

Re: Add a "blueprint as" property

I seem to be missing something because I can't work out where to find/replace in that situation. All that event gives me is the player index, and I don't see anything in the LuaPlayer API that is useful here.
by GotLag
Tue Mar 26, 2019 2:22 pm
Forum: Modding discussion
Topic: Removing fluid temperature - thoughts?
Replies: 93
Views: 11823

Re: Removing fluid temperature - thoughts?

I can't think of any application that needs fluid temperature. Even a mod like my old Reactors didn't need fluid temperature - if I made it again today I would be outputting steam instead of heated water, and I could just as easily adjust the amount of high-temperature steam produced as its temperat...
by GotLag
Tue Mar 26, 2019 12:19 pm
Forum: Modding interface requests
Topic: Add a "blueprint as" property
Replies: 4
Views: 474

Add a "blueprint as" property

Is it feasible to add a field to prototypes to allow that entity/tile to be replaced with another entity/tile in blueprints? There are times when a mod needs to swap out an entity at some point after it's built, and this currently breaks blueprints made after that swap. Three example uses: Make all ...
by GotLag
Thu Mar 21, 2019 1:47 pm
Forum: Implemented Suggestions
Topic: Minor graphical suggestion: landfill sprite change
Replies: 3
Views: 462

Minor graphical suggestion: landfill sprite change

I'd like to suggest that the landfill tile takes its appearance from, say, dirt-3 instead of grass-1. Having landfilled tiles look like muddy dirt instead of pristine grass seems a lot more fitting. Am I correct in thinking that the use of grass-1 is a holdover from when grass was the only tile allo...
by GotLag
Mon Mar 18, 2019 12:45 pm
Forum: Resolved Problems and Bugs
Topic: [0.17.14] Autosaving with autosave interval set to "Never"
Replies: 5
Views: 509

Re: [0.17.14] Autosaving with autosave interval set to "Never"

Oh, sorry, I didn't clarify. I did not save any changes.
by GotLag
Mon Mar 18, 2019 12:33 pm
Forum: Resolved Problems and Bugs
Topic: [0.17.14] Autosaving with autosave interval set to "Never"
Replies: 5
Views: 509

Re: [0.17.14] Autosaving with autosave interval set to "Never"

%APPDATA%\Factorio\config\config.ini shows autosave-interval=101
by GotLag
Mon Mar 18, 2019 4:37 am
Forum: Resolved Problems and Bugs
Topic: [0.17.14] Autosaving with autosave interval set to "Never"
Replies: 5
Views: 509

[0.17.14] Autosaving with autosave interval set to "Never"

I have autosave interval set to "Never" but my game is being auto-saved every 101 minutes - I have two autosaves of my current test map with play times of 01:41 :00 and 03:22:00 When I click "Never" in the save settings I see the textbox value is 101, when I drag the slider aroun...
by GotLag
Sun Mar 17, 2019 5:46 pm
Forum: Modding interface requests
Topic: More shortcut button API features please
Replies: 1
Views: 304

Re: More shortcut button API features please

Gah, I looked at the API but didn't find the shortcut features because they're in LuaPlayer for some reason:
https://lua-api.factorio.com/latest/Lua ... ut_toggled
by GotLag
Sun Mar 17, 2019 11:40 am
Forum: Modding interface requests
Topic: More shortcut button API features please
Replies: 1
Views: 304

More shortcut button API features please

I've been experimenting with shortcut buttons and there are a few features I feel are currently lacking. I think these are pretty obvious so they're probably already on somebody's to-do list or even being worked upon, but: Respect the prototype's technology_to_unlock setting - currently this does no...
by GotLag
Sun Mar 17, 2019 2:48 am
Forum: Resolved Problems and Bugs
Topic: [0.17.14] Recipes with more than one instance of the same ingredient
Replies: 34
Views: 6690

Re: [0.17.14] Recipes with more than one instance of the same ingredient

I was really tired when I posted this, or I would have thought of another possibility: if a recipe has multiple entries for a single item type, consolidate them into a single entry. So the recipe in my first post would become: ingredients = { {"copper-cable", 7}, {"electronic-circuit&...
by GotLag
Sat Mar 16, 2019 7:41 pm
Forum: Resolved Problems and Bugs
Topic: [0.17.14] Recipes with more than one instance of the same ingredient
Replies: 34
Views: 6690

Re: [0.17.14] Recipes with more than one instance of the same ingredient

Yeah I'm not aching to see this fixed somehow, but I feel it's an odd behaviour that the devs should at least be aware of (if they're not already).
by GotLag
Sat Mar 16, 2019 7:32 pm
Forum: Resolved Problems and Bugs
Topic: [0.17.14] Recipes with more than one instance of the same ingredient
Replies: 34
Views: 6690

[0.17.14] Recipes with more than one instance of the same ingredient

In the process of testing a mod I ended up with a recipe containing the following ingredients: ingredients = { {"copper-cable", 5}, {"electronic-circuit", 2}, {"copper-cable", 1}, {"copper-cable", 1} } In-game this shows up in tooltips and assemblers as having...
by GotLag
Thu Mar 14, 2019 11:49 pm
Forum: Gameplay Help
Topic: [0.17.9] I can't get the speakers to work! [SOLVED]
Replies: 7
Views: 701

Re: [0.17.9] I can't get the speakers to work! [SOLVED]

Don't worry about it, I've made much dumber mistakes
by GotLag
Thu Mar 14, 2019 1:43 pm
Forum: Gameplay Help
Topic: [0.17.9] I can't get the speakers to work! [SOLVED]
Replies: 7
Views: 701

Re: [0.17.9] I can't get the speakers to work!

I mean do you have enough power to the speaker? Might the speaker be working when you disable Electric Furnaces because that reduces your power draw? A quick sandbox test shows that the speaker stops working when it has <50% power.
by GotLag
Thu Mar 14, 2019 11:38 am
Forum: Gameplay Help
Topic: [0.17.9] I can't get the speakers to work! [SOLVED]
Replies: 7
Views: 701

Re: [0.17.9] I can't get the speakers to work!

Maybe dumb question: is the speaker powered in the save in which it doesn't work?

Go to advanced search